Closed Bug 181660 Opened 22 years ago Closed 22 years ago

When addressing a message, Moz freezes.

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 168517

People

(Reporter: Bugzilla, Assigned: racham)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
Build Identifier: beta 1.2b windows exe

I experienced a problem with the address book. So, I reinstaled Moz & it 
cleared up. However, it came back. Now I cannot get it to work. I reinstalled 
Moz 1.1 & it is working. The full error message I get on startup of Moz after 
reinstalling 1.2 is "The procedure entry point ??1nsAVLTree@@QAE@XZ could not 
be located in the dynamic link library xpcom.dll."

Reproducible: Always

Steps to Reproduce:
1. Open mail app, Compose a new or forward an existing message
2. Type an address & send or Click on Address icon. 


Actual Results:  
Moz froze

Expected Results:  
Opened Address book or sent message.
Sounds like Mozilla is finding and loading an inconsistant version of xpcom.dll.
 Can you check whether there is more than one file named xpcom.dll on your system?
Bingo! There's one in the OpenOffice folder from 4/29/2002 6:00 AM - 455,680
bytes & one in the Mozilla folder from 8/26/2002 12:28 PM - 518,448 bytes.
However, since they are in application folders, shouldn't they load the one in
their own path? 
You installed the spellchecker.
You need an updated version which is not availible at the moment (Afaik)

This is no Mozilla problem.

XPCOM is part of mozilla but it's not the cause for such errors

*** This bug has been marked as a duplicate of 168517 ***

*** This bug has been marked as a duplicate of 168517 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
I'd say it is a Moz problem, I installed the compiled build, not the
spellchecker separately. If the pieces of Moz that come bundled don't play nice
together, that's a problem.
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.