Closed Bug 1816784 Opened 1 year ago Closed 1 year ago

Message header buttons should be keyboard accessible/focusable

Categories

(Thunderbird :: Disability Access, task)

Thunderbird 102

Tracking

(thunderbird_esr102 wontfix, thunderbird112 fixed)

RESOLVED FIXED
113 Branch
Tracking Status
thunderbird_esr102 --- wontfix
thunderbird112 --- fixed

People

(Reporter: thomas8, Assigned: solange)

References

Details

(Keywords: access)

Attachments

(1 file)

From Elizabeth's accessibility analysis

Message header buttons (Reply etc.) should be keyboard accessible

STR

  • select a message in message list
  • press Tab and see if you can reach message header buttons somehow (even with other keys)

Actual

  • not keyboard accessible/focusable (but real keyboard shortcuts exist, thus not a big problem)

Expected

  • Message header buttons (Reply etc.) should be keyboard accessible
  • Consider just having a single tab stop on the first button, and make other buttons available via arrow keys. Having too many tabstops in a small UI area may make keyboard navigation inefficient.

This isn't caused by Supernova, so setting 102. Feel free to change that, which will increase the chances of this getting picked up.

Assignee: nobody → solange
See Also: → 1819281
Duplicate of this bug: 1589862
Attachment #9323726 - Attachment description: WIP: Bug 1816784 - Message header buttons should be keyboard accessible/focusable. → Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth
Attachment #9323726 - Attachment description: Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth → WIP: Bug 1816784 - Message header buttons should be keyboard accessible/focusable.
Attachment #9323726 - Attachment description: WIP: Bug 1816784 - Message header buttons should be keyboard accessible/focusable. → Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth
Status: NEW → ASSIGNED
Attachment #9323726 - Attachment description: Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth → WIP: Bug 1816784 - Message header buttons should be keyboard accessible/focusable.
Attachment #9323726 - Attachment description: WIP: Bug 1816784 - Message header buttons should be keyboard accessible/focusable. → Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth
Blocks: 1825904
Target Milestone: --- → 113 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8ffeb828505a
Message header buttons should be keyboard accessible/focusable. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9323726 [details]
Bug 1816784 - Message header buttons should be keyboard accessible/focusable. r=aleca,elizabeth

[Triage Comment]
Approved for beta

Attachment #9323726 - Flags: approval-comm-beta+
Depends on: 1826659
Regressions: 1826997
See Also: → 1827199
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: