Closed Bug 1816977 Opened 1 year ago Closed 1 year ago

cannot set per-contact preferred mail format (HTML/plaintext)

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: steve, Unassigned)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [removed feature])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/109.0

Steps to reproduce:

It used to be possible to set the preferred mail format (text or html) on a per-contact basis. The field is now gone from the GUI, I don't know when it was removed. As of v91 the PreferMailFormat setting in the address book was apparently still recognized and respected. As of v102 the field (if present in abook.sqlite) is ignored.

Thunderbird 102.7.2 (64-bit)
macOS Monterey 12.6.3

Actual results:

There's no way to set the preferred email format per-contact. Mail format is determined by the global setting.

Expected results:

There should be a way to set the preferred email format per-contact.

There's no way to set the preferred email format per-contact. Mail format is determined by the global setting.

That's correct Steve. We removed that option deliberately, because it had outlived its purpose, was badly implemented and pretty much unpredictable in outcome except for simple cases.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Untriaged → Address Book
Resolution: --- → WONTFIX
See Also: → 1727493
Keywords: regression
Regressed by: 1758460
Whiteboard: [removed feature]
Summary: Cannot set per-contact preferred mail format → cannot set per-contact preferred mail format (HTML/plaintext)
You need to log in before you can comment on or make changes to this bug.