Closed Bug 1817088 Opened 1 year ago Closed 1 year ago

Hazard analysis crashes when reporting hazards due to function pointer

Categories

(Core :: JavaScript: GC, defect, P1)

defect

Tracking

()

RESOLVED FIXED
112 Branch
Tracking Status
firefox-esr102 --- wontfix
firefox110 --- wontfix
firefox111 --- wontfix
firefox112 --- fixed

People

(Reporter: sfink, Assigned: sfink)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1685586 introduced a crash if you ever have a hazard in a function due to a call to a function pointer. The hazard jobs have not been red for the last year because they produce no hazards at all, let alone ones with function pointers. Also, the problem does not occur if you call a function that itself calls a function pointer, which is the usual case.

Assignee: nobody → sphink
Status: NEW → ASSIGNED

Set release status flags based on info from the regressing bug 1685586

Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e5537e7a008
Allow hazards involving an indirect call (through a function pointer) without crashing the analysis. r=jonco
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: