Country selection not possible

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Egon Face, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

When I try to select a country from the list on the right in
http://www.visa.com/globalgateway/gg_selectcountry.html?retcountry=1 I get a pop
up error message which says "Javascript application: Please select a region"
which is fine, so I select a region and then I am provided a list of countries.
When I click on this I am back to the start - i.e. a blank list of countries on
the right.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.visa.com/
2. Get redirected to
http://www.visa.com/globalgateway/gg_selectcountry.html?retcountry=1
3. Select a region
4. Select a country

Actual Results:  
5. Verify the list is cleared with no other action

Expected Results:  
Redirection to the site specific to your country and region

Javascript console shows no errors

Comment 1

16 years ago
Not JS Engine; reassigning to Browser-General for now -

The site WORKSFORME using Mozilla trunk binary 2002112108 on WinNT.
When I follow steps 1-4 above, I arrive at the correct country page.
For example, after choosing North America as a region and clicking
on Canada as the country, I am correctly sent to:

  http://www.international.visa.com/?country=ca&ep=v_gg_return


egonface@hotmail.com: 

1. Do you still see the bug with an up-to-date build?

2. If so, what happens if you try using a new Mozilla profile?
   You can force the Profile Manager to come up (if it doesn't
   already) by launching Mozilla from a console window like this:

        [(path to Mozilla)] ./mozilla -profilemanager

   Once this comes up, click on "Create Profile" and see if that
   makes any difference - thanks.
Assignee: rogerl → asa
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → asa
(Reporter)

Comment 2

16 years ago
OK I added a new profile so it works for me as well now. Must have been
something specific to my profile or that session which I suspected with such a
high profile site. Sorry for the false alarm!

Comment 3

16 years ago
egonface@hotmail.com: thanks. Per your findings, resolving 
this as WORKSFORME -
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.