Closed Bug 1817292 Opened 1 year ago Closed 1 year ago

Message header text background buttons dark theme issues

Categories

(Thunderbird :: Theme, defect)

Thunderbird 112
Unspecified
macOS
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- fixed

People

(Reporter: NicolasWeb, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

Steps to reproduce:

  1. Open TB (for me macOS 10.13.6, that do not support natively system dark theme)
  2. Switch TB to use Dark theme

Actual results:

The message header stay white and not respect dark theme:

  1. Background
  2. Text
  3. Buttons (and their borders)
  4. Icons

Expected results:

All the message header should adapt to dark theme, like any part of TB.

Regression : works in TB 110.b4

See Also: → 1707273
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Unspecified → macOS
Whiteboard: [Supernova]
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Target Milestone: --- → 112 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d6bd1935daab
Use layout.css colors for the message header. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9318560 [details]
Bug 1817292 - Use layout.css colors for the message header. r=aleca

[Approval Request Comment]
Regression caused by (bug #): [Supernova]
User impact if declined: on older macOS incorrect message header colour
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9318560 - Flags: approval-comm-beta?

Comment on attachment 9318560 [details]
Bug 1817292 - Use layout.css colors for the message header. r=aleca

[Triage Comment]
Approved for beta

Attachment #9318560 - Flags: approval-comm-beta? → approval-comm-beta+
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: