return true from form onsubmit is broken

VERIFIED FIXED

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Tony Gorman, Assigned: Mike McCabe)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
A form which calls a javascript function from the onsubmit handler fails.
E.G

<form onsubmit="return jsFunc()">

even if jsFunc() merely returns true, the form is not submitted.
(Reporter)

Updated

18 years ago
Summary: onsubmit action of forms is broken → return true from form onsubmit is broken
(Reporter)

Comment 1

18 years ago
Test page as follows. This should work but doesn't. I am using a PC with
win98. Running win32 M10.

<HTML><HEAD><TITLE>Test Case</TITLE></HEAD><BODY>
<SCRIPT language=JavaScript>
function retCheck(fObj) {
return true;
}
</SCRIPT>

<FORM onsubmit="return retCheck()" target="whatever.htm" method="post"
name="moz"><INPUT type=SUBMIT value="Test1"></FORM>
</BODY></HTML>
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

18 years ago
Sorry, was working on a different bug and misread the causes. Was never a bug...

Comment 3

17 years ago
should be invalid, but to cut down on spam, vrfy fixed per reporter's comments 
(testcase at URL given is no longer valid, btw)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.