Translated Pages in Chinese, Japanese and Korean do not display properly.

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: surajrai, Assigned: bryner)

Tracking

({intl})

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021122 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021122 Chimera/0.6+

In the URL listed above it seems that English -> Chinese/Japanese/Korean
translation do not render properly.  



Reproducible: Always

Steps to Reproduce:
1) Go to the above URL and enter the word "Hello" in the "Translate a block
text" section.

2) Select "English to Japanese" in the drop-down list and click on the Translate
button.

Actual Results:  
The translated text shows ....


Expected Results:  
It should have displayed こんにちは.
(Reporter)

Comment 1

16 years ago
I noticed after posting the bug that the Bugzilla page also does not display the
Japanese characters that I typed in the "Expected Results" section properly but
that might be an entirely different thing.

Comment 2

16 years ago
This is a prob with Babelfish.
(Reporter)

Comment 3

16 years ago
But it displays fine in IE. So unless they have specifically blocked out non-IE
browsers...I would think it may be related to Chimera as well?

Comment 4

16 years ago
They have changed something recently, hard to say what, but I know Babelfish
worked fine just a week ago.

Now they deliver dots (real dots, not missing glyphs) instead of translated glyphs.

If I spoof the useragent string on the fly in Privoxy (a filtering proxy), it
works fine, so they have an amateurish server-side sniffing. Tech evangelism, if
you ask me.

I am using Mozilla 1.2rv, so they are probably blocking either Gecko or Mozilla/5.0.

Spoofing with Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC) works.

Comment 5

16 years ago
More evidence of the Niklas's theory:
If you save the source from IE and load it in Chimera, all of the characters
display correctly. So why would Babelfish want to send dots instead of foreign
characters? What purpose could that possibly serve?

Comment 6

16 years ago
Reproduced using FizzillaMach/2002112207 and Chimera/2002112204. Is this TE?

Comment 7

16 years ago
*** Bug 182074 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
AV changed all their layout 2 weeks ago, new style, new launch etc. It has been
present since then.

Other systran powered sites work fine.

Can someone confirm please?

Comment 9

16 years ago
babelfish <tools@support.altavista.com>

I have emailed them 3 times about this, they never reply with anything other
than an IE download link

Regards

JG
(Reporter)

Comment 10

16 years ago
I just tested it on Mozilla 1.2b for Windows and it does not work there as well.
 It seems that they have built the site specifically for IE.

I will also e-mail babelfish <tools@support.altavista.com> and hopefully with
more people e-mailing we will get their attention.

Comment 11

16 years ago
Hi,

They seem to be doing something at last, its odd that they only block Asian from
mozilla.

I dont know if they will bother to fix it, finaly, so the more people that email
the better I think.

Please change to OS all and hardware all

Regards

JG

AltaVista Tool Support wrote:
> Dear AltaVista User,
> 
> Thank you for choosing AltaVista.
> 
> We have forwarded your email to our engineering team for further 
> investigation. We apologize for any inconvenience and thank you for your
> patience.
> 
> If you have any further questions, please feel free to contact us again.
> 
> Regards,
> AltaVista Support Team
> 
> Original Message Follows:
> ------------------------
> are you aware that babelfish is blocking Mozilla?
> 
> http://bugzilla.mozilla.org/show_bug.cgi?id=181742
> 
> 
> Please investigate/correct this bug.
> 
> 
> Please let me know when it is resolved
> 
> 
> Best regards
> 
> JG
> 
> 

Comment 12

16 years ago
This not only existing in Chimera, but also for Windows.  Change component to
intl and platform to All.
Status: UNCONFIRMED → NEW
Component: Page Layout → Internationalization
Ever confirmed: true
Keywords: intl
Product: Chimera → Browser
Version: unspecified → Trunk

Comment 13

16 years ago
Setting All/All per comment 12.
OS: MacOS X → All
Hardware: Macintosh → All

Comment 14

16 years ago
Hi,
Does anyone have a higherlevel contact at AV? I now see "???" instead of "..."

JG

Comment 15

16 years ago
Fixed.

Comment 16

16 years ago
Its not fixed here

JG

Comment 17

16 years ago
I enter "pen", I translate to Chinese, I get "笔" (bĭ).

I enter "Japan", I translate to Japanese, I get "日本" (nippon).

Comment 18

16 years ago
D'oh! Forgot that I added a spoof to Privoxy... sorry!

Comment 19

16 years ago
Any progress anyone?
(Reporter)

Comment 20

16 years ago
Hooray!  It is working again!!!

Comment 21

16 years ago
Wow! nice, they emailed me a few days ago, so i explicitly stated what they need
to do to fix it! seems it worked :)

Something funny i've learned out of this, chinese character woman+child, which
in japanese means like/love; in chinese it means hello! interesting.. Shame
Korean does not use many chinese characters nowadays

JG

-------- Original Message --------
Subject: Re: babelfish is blocking Mozilla        (KMM3129833V23546L0KM)
Date: Mon, 16 Dec 2002 15:03:36 +0000
From: J. Grant <jg-xxxxxxg>
To: AltaVista Tool Support <tools@support.altavista.com>,	lxxxxxxk.org
References: <200212160612.gBG6Cs3R016264@support2.sv.av.com>

Hello,

Thank you for the reply.

Problems that still need resolving:

1)
Your HTML is badly written, each page has this header
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
This means each page that might have a chance of displaying a charset 
other than latin based is certain to fail. Please correct this, change 
to UTF-8 this is much better for languages, configure systran to output 
like this.
<meta http-equiv="content-type" content="text/html; charset=UTF-8">

2) You are checking for "Microsoft Internet Explorer" in the browser ID, 
this is bias and unworkable, please stop blocking Mozilla and other 
browsers. Bug verfied by changing browser ID in Konquerer to IE 
compatible string.(site worked ok after)


These are significant problems, please forward this email to all senior 
managers on this project, or provide me with more useful contact emails 
so /we/ can get this problem fixed. AV is getting a bad reputation for 
this.


Regards


JG



AltaVista Tool Support wrote:
> We have forwarded your email to our engineering team for further 
> investigation. We apologize for any inconvenience and thank you for your
> patience.
> 
> 
> 
> 
> I think some of the complaints
> http://bugzilla.mozilla.org/show_bug.cgi?id=181742 were for the encoding
> bug
> jeff eventually fixed, others have to do with users not knowing that 
> they
> need to download Asian fonts (from the Mac Installation disks) for 
> babelfish
> to work properly for Asian languages.
> 
> Hartmut and I just tried translations on a couple of Macs with browser 
> info
> as follows:
> Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2) Gecko/20010726
> Netscape6/6.1
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4) Gecko/20011126
> Netscape6/6.2.1
> (note: the same Mac OS in the bug report)
> We also saw "???" before we downloaded the fonts, but after we got the 
> fonts
> the problem quickly went away.
> 
> Hartmut, I think we should add some text on the result page to make 
> users
> aware of the font issue.
> 
> Michelle
> 
> -----Original Message-----
> From: Alastair Gourlay 
> Sent: Monday, December 09, 2002 10:18 AM
> To: Michelle Yeh; Erik Jessen
> Subject: FW: babelfish is blocking Mozilla (KMM3122317V21380L32986KM)
> 
> 
> 
> Not sure who is on the support Front-End list..  seems like they
> could submit this as a bug.
> 
> -----Original Message-----
> From: AltaVista Tool Support [mailto:tools@support.altavista.com]
> Sent: Monday, December 09, 2002 12:11 AM
> To: Front-End
> Subject: Re: babelfish is blocking Mozilla (KMM3122317V21380L32986KM)
> 
> 
> ******  This is a Collaborated message from the AltaVista Support 
> Team.****** Your input is requested to resolve an issue that could not 
> be addressed by the Support Team.  Click "Reply" and respond to the 
> inquiry from the end user.
> 
>  Please note that your response will go back to an AltaVista Support 
> Team member for review prior to returning it to the end user. Your 
> e-mail address will be stripped and replaced with a support address 
> prior to sending back to the end user. Please delete this text and your 
> signature file (and any other text in the message that includes your 
> name) before sending the message. 1583627 ******jg-xxxg
> 
> 
> 
> Original Message Follows:
> -------------------------
> 
> Hi,
> 
> Can you confirm you are processing this bug in your web site please?
> 
> Could you tell me when you will be resolving it?
> 
> We have not publicided the fact that you are blocking non IE browsers 
> yet, avoiding bad publicity for AV.
> 
> Best regards
> 
> JG
> 
> AltaVista Tool Support wrote:
> 
>>Dear AltaVista User,
>>
>>Thank you for choosing AltaVista.
>>
>>We have forwarded your email to our engineering team for further 
>>investigation. We apologize for any inconvenience and thank you for 
> 
> your
> 
>>patience.
>>
>>If you have any further questions, please feel free to contact us 
> 
> again.
> 
>>Regards,
>>AltaVista Support Team
>>
>>Original Message Follows:
>>------------------------
>>are you aware that babelfish is blocking Mozilla?
>>
>>http://bugzilla.mozilla.org/show_bug.cgi?id=181742
>>
>>
>>Please investigate/correct this bug.
>>
>>
>>Please let me know when it is resolved
>>
>>
>>Best regards
>>
>>JG
>>
>>

Comment 22

15 years ago
Thank you for your persistence to make Altavista fix this bug (I remember
writing to them a couple of times in the past to no avail).
I'm filing this as fixed.
Anyway, this bug should have been filed under tech-evangelism (Mozilla doesn't
do anything wrong). 

>Something funny i've learned out of this, chinese character woman+child, which
> in japanese means like/love; in chinese it means hello!

Both meanings are related. U+597D (好 :'woman + child') means 'good, well, fine,
excellent' (from which 'how good are you' -> 'hello' is derived) and 'like/love'
because 'women like/love their children'. If you want to know the meaning of a
_characte_', you should look up a decent Hanzi/Kanji/Hanja (__character__)
dictionary (or UniHan DB) instead of C-E/E-C, J-E/E-J, or K-E/E-K dictionary.


> Shame Korean does not use many chinese characters nowadays

  ??  There are a number of Korean words with the character (woman + child)
meaning 'fine/well/good'(호경기 : 好經期 : economically good time : booming
economy or호감 : 好感 : feeling of being attracted, attraction, good impression) ).

BTW, if you want to enter non-ASCII characters in bugzilla, make sure to set
View | Charaacter Coding to UTF-8.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Component: Internationalization → Japanese
Product: Browser → Tech Evangelism
Resolution: --- → FIXED
Version: Trunk → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.