Java plugin doesn't work

RESOLVED INVALID

Status

RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: rjl, Assigned: joe.chou)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123

The following works in Konqueqor but doesn't display in Mozilla using
the same JavaVM (blackdown-jre-1.3.1) (I've also tried Sun's JavaVM
j2re1.4.1_01 in Mozilla and it doesn't work).

http://www.nusaweb.com/chat.html

Reproducible: Always

Steps to Reproduce:
1. Set the JavaVM plugin to blackdown-jre-1.3.1 and then Sun's j2re1.4.1_01.
2. In Mozilla, go to http://www.nusaweb.com/chat.html
3. In Konqueror, go to http://www.nusaweb.com/chat.html

Actual Results:  
In Mozilla the Java applet was blank or had the coffee cup symbol.
In Konqueror the Java applet displayed the "Your name" and "Your profile" text
entry boxes.


Expected Results:  
The Java applet should have displayed the "Your name" and "Your profile" text
entry boxes.

What causes this?

Comment 1

16 years ago
wfm using build 2002112304 on Win2k + JRE 1.4.1_04.
How did you install JRE for Mozilla ? Do you have a proper symlink ? Does
about:plugins list Java ?
Component: Plug-ins → OJI

Comment 2

16 years ago
wfm using build 2002112305 on Linux + JRE 1.4.1_01.
Assignee: beppe → joe.chou
QA Contact: shrir → petersen
(Reporter)

Comment 3

16 years ago
Created attachment 107301 [details]
my about:plugins
Mozilla use a different plugin API.
Can you please try it again with JRE1.4.1 since SUN fixed many problems since
1.3.1 for Mozilla.
You can't save about:plugins :-)

BTW: Do you use a mozilla.org build ,self-compiled build or a build from
somewhere else ?
(Reporter)

Comment 6

16 years ago
Nighly binary downloaded from mozilla.org.

Mozilla 1.3a
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021123

Java(TM) Plug-in 1.4.1_01-b01

The Java coffee cup displayed the first time:
http://www.nusaweb.com/chat.html
After reloading there was a grey blank space.

Since it works for someone else, how can I find out what's wrong with my system?
(Reporter)

Comment 7

16 years ago
I tried a really old version of Mozilla
Mozilla 1.1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
and it still doesn't work.
Since the problem appears to be isolated to my system, I'll need to debug it.
How can I do this?

Comment 8

16 years ago
Works for me using the same configuration noted in comment #2.

This applet appears to contain some audio support. Java may be blocking as it
tries to open your audio device. You mention konqueror so you're probably
running kde, including artsd, the kde sound daemon. Try running mozilla via the
artsdsp program, e.g. "artsdsp mozilla". If you're using gnome, the equivalent
utility is esddsp. These utilities catch attempts to open the audio device
directly, and route the audio to the appropriate daemon instead.

Please update this bug report with the results.
(Reporter)

Comment 9

16 years ago
Yeah, thanks.
I didn't think of trying mozilla with "artsdsp mozilla".
It works that way.
Is there a way I can set the Java plugin to ignore audio requests?
This seems tricky, I'm surprised this doesn't happen more often (maybe it will :-)).

Comment 10

16 years ago
Bob, thanks for the response. Unfortunately I don't know any way to affect
java's behavior here. If you're motivated, you could go to
<http://java.sun.com/> and submit an RFE to their bug database, or try to start
a discussion in one of their forums.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.