Closed Bug 181783 Opened 20 years ago Closed 20 years ago

mozilla beeps after typing text in location bar for the first time

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows 98
defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 182451

People

(Reporter: hfmeza, Assigned: aaronlev)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows 98; en-US; rv:1.3a)  Gecko/20021123 Netscape/7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows 98; en-US; rv:1.3a)  Gecko/20021123 

When you open mozilla, the first character that is typed in the location bar
causes a beep. This only happens the first time, after that, if new windows or
tabs are used, there is no beep. 

If you close mozilla, and open it again, the beep occurs again

Reproducible: Always

Steps to Reproduce:
1. Start mozilla
2. Type a character in the location (URL) bar
3.

Actual Results:  
a beep sounds (like the beep that sounds where there is an error)

Expected Results:  
There should have been no sound
Do you get the same "beep" in Typeahead ?
(click in the content Are and press 3x "g" ..
Re: comment #1

It also happens if I click in the content area and try to do a TypeAhead Find,
but only the first time. After that, URL bar doesn't beep unless Mozilla is
closed and reopened. Apparently, typing in URL bar will avoid Typeahead beeping,
and viceversa.

Also, if you want a better explanation on how the "beep" sounds, check ding.wav
in windows platforms. I don't know how it sounds in ohter platform. 
I Have that with 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021122
at _any_ browser-input-pane, for example sidebar-bookmark-search:

1. Mouseclick into pane
2. input first character, and immediately "bing"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached audio sounds like DI'NG.WAV
It soukds like tha attatched WAV, but I do not think, that that sound-file is
used by mozilla.
-> Editor:Core 
Assignee: asa → jfrancis
Component: Browser-General → Editor: Core
QA Contact: asa → sujay
This is really annoying. and relatively new. Did something get checked in
recently to cause this?

This happens for me with the first keypress in a mozilla window. Entering text
into the location bar, a form input, etc.

This is *not* the same burping sound as the type-ahead-find error sound. This is
distinctly one of the windows sounds.
I really doubt this is editor.  Just like there is no crying in baseball, there
is no beeping in editor (although there used to be a beppe in editor).

Handing off to Charlie becasue I suspect he has a working windows build, but I
assume he will reassign.
Assignee: jfrancis → cmanske
-->URLBar
Assignee: cmanske → hewitt
Component: Editor: Core → URL Bar
QA Contact: sujay → claudius
I don't see this on my Mac mozilla build.
brade: i send this to Editor:core because of comment #3:
_any_ browser-input-pane, for example sidebar-bookmark-search:
I see (or hear) this with build 2002120708 on Win98. But if I turn off
typeaheadfind by setting the pref to false, it goes away.

Could perhaps the patch in bug 176602 be the culprit here?
Assignee: hewitt → aaronl
Component: URL Bar → Keyboard Navigation
QA Contact: claudius → sairuh
Possibly related to bug 182451.
Possibly related to bug 182451.
Blocks: isearch
Status: NEW → ASSIGNED
Yes, it's the same bug. I don't know which one you want to keep so I will leave
the duping to you.
dupping

*** This bug has been marked as a duplicate of 182451 ***
No longer blocks: isearch
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Have you set any typeahead prefs in your prefs.js file?
v dup
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.