Closed Bug 1817870 Opened 1 year ago Closed 1 year ago

Unread messages no longer standing out enough in message list with TB's Dark theme, as read messages are now brighter than before

Categories

(Thunderbird :: Theme, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- fixed

People

(Reporter: NicolasWeb, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

(Keywords: polish, regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

Steps to reproduce:

  1. Set the dark theme
  2. Open a folder with an unread message

Actual results:

Hard to differentiate the unread and read message in message list. It's not enough obvious

Expected results:

It should be more obvious, from the first and rapid sight.

Regression : It was the case in TB 102 and TB110b4

In the screenshot, compare how it is easy to identify read status of bug 1811366 in the list

Thanks Nicolas, well-formed bug report as usual :-)

Confirming for 112.0a1 (2023-02-22) (64-bit), Win10, TB Dark theme.

Richard, can we tone down the text color of read messages in the list to be more greyish as before? In supernova, read messages seem to be bright white just like unread messages, which makes them harder to distinguish as bold print is now the only distinction.

Blocks: sn-msglist
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(richard.marti)
Keywords: polish, regression
Summary: Unread message not enough obvious in message list with Dark theme → Unread message not standing out enough in message list with TB's Dark theme
Whiteboard: [supernova]
Summary: Unread message not standing out enough in message list with TB's Dark theme → Unread messages not standing out enough in message list with TB's Dark theme, as read messages are now brighter than before
Summary: Unread messages not standing out enough in message list with TB's Dark theme, as read messages are now brighter than before → Unread messages no longer standing out enough in message list with TB's Dark theme, as read messages are now brighter than before

Alex, actually we use --color-ink-10 for the tree with dark theme. How about using --color-gray-20 instead?

Flags: needinfo?(richard.marti) → needinfo?(alessandro)

That should work.
Make sure to get at least a AA score in the contrast checker. https://webaim.org/resources/contrastchecker/

Flags: needinfo?(alessandro)
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Target Milestone: --- → 112 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/65e6ff9d8293
Make the tree text color a bit darker with dark theme. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9319527 [details]
Bug 1817870 - Make the tree text color a bit darker with dark theme. r=aleca

[Approval Request Comment]
Regression caused by (bug #): [Supernova]
User impact if declined: on dark themes not good visibility of unread messages
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9319527 - Flags: approval-comm-beta?

Comment on attachment 9319527 [details]
Bug 1817870 - Make the tree text color a bit darker with dark theme. r=aleca

[Triage Comment]
Approved for beta

Attachment #9319527 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1819544
No longer duplicate of this bug: 1819544
Whiteboard: [supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.