Random crashing, everything Mozilla shuts down.

RESOLVED DUPLICATE of bug 154699

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 154699
16 years ago
8 years ago

People

(Reporter: David Snyder, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.22; Mac_PowerPC)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

Here is the crash log that OS X gave me: 

**********

Date/Time:  2002-11-25 11:08:02 -0700
OS Version: 10.2.2 (Build 6F21)
Host:       David-Snyders-Computer.local.

Command:    Mozilla
PID:        395

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000034

Thread 0:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9284ee30 in JVM_GetCPMethodClassNameUTF
 #4   0x92861a94 in JVM_Send
 #5   0x9285eb14 in JVM_FillInStackTrace
 #6   0x92868468 in JVM_DoPrivileged
 #7   0x9288e0e0 in JVM_GetMethodIxExceptionTableEntry
 #8   0x92883e80 in JVM_DefineClass
 #9   0x929bce6c in eh_rest_world_r10
 #10  0x92845840 in JVM_Yield
 #11  0x92899bd0 in JVM_Open
 #12  0x05510b90 in 0x5510b90
 #13  0x0551ddb0 in 0x551ddb0
 #14  0x0551ff08 in 0x551ff08
 #15  0x05512e60 in 0x5512e60
 #16  0x0541068c in 0x541068c
 #17  0x0541068c in 0x541068c
 #18  0x054105cc in 0x54105cc
 #19  0x054105cc in 0x54105cc
 #20  0x054105cc in 0x54105cc
 #21  0x054105cc in 0x54105cc
 #22  0xa2843c38 in _ZTSSt13bad_exception
 #23  0x92838bdc in JVM_CurrentTimeMillis
 #24  0x92872ed4 in JVM_GetCPClassNameUTF
 #25  0x92865c80 in JVM_DoPrivileged
 #26  0x05412668 in 0x5412668
 #27  0x054105cc in 0x54105cc
 #28  0xa2843c38 in _ZTSSt13bad_exception
 #29  0x92838bdc in JVM_CurrentTimeMillis
 #30  0x92872ed4 in JVM_GetCPClassNameUTF
 #31  0x9288f144 in JVM_MonitorNotifyAll
 #32  0x9285fd68 in JVM_GetCPFieldSignatureUTF
 #33  0x92844a98 in JVM_GetClassLoader
 #34  0x92875e64 in JVM_GetCPClassNameUTF
 #35  0x9288199c in JVM_DefineClass
 #36  0x92869ed4 in JVM_DoPrivileged
 #37  0x928480dc in __moddi3
 #38  0x05418d7c in 0x5418d7c
 #39  0xa2843c38 in _ZTSSt13bad_exception
 #40  0x92838bdc in JVM_CurrentTimeMillis
 #41  0x92872ed4 in JVM_GetCPClassNameUTF
 #42  0x9288f144 in JVM_MonitorNotifyAll
 #43  0x9285fd68 in JVM_GetCPFieldSignatureUTF
 #44  0x92844a98 in JVM_GetClassLoader
 #45  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #46  0x92844a98 in JVM_GetClassLoader
 #47  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #48  0x92844a98 in JVM_GetClassLoader
 #49  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #50  0x92844a98 in JVM_GetClassLoader
 #51  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #52  0x92844a98 in JVM_GetClassLoader
 #53  0x928452e8 in JVM_GetMethodIxExceptionTableLength
 #54  0x928a22c4 in JVM_Close
 #55  0x8cfd23e4 in 
_ZN43com_apple_mrj_JavaEmbedding_JE_AppletViewer20intitializeMet
hodIDsEP7JNIEnv_
 #56  0x8cfd1dec in _Z23intitializeAllMethodIDsP7JNIEnv_
 #57  0x8cfd3068 in _Z17InitJavaEmbeddingRP7JNIEnv_
 #58  0x8cfd57d4 in CreateJavaApplet
 #59  0x02891734 in loadApplet__10MRJContextFv
 #60  0x02892298 in setWindow__10MRJContextFP14nsPluginWindow
 #61  0x0288dea4 in 
SetWindow__17MRJPluginInstanceFP14nsPluginWindow
 #62  0x027eabec in 
InstantiateEmbededPlugin__16nsPluginHostImplFPCcP6nsIURIP22nsI
 #63  0x02bc1124 in 
InstantiatePlugin__13nsObjectFrameFP14nsIPresContextR19nsHTMLR
 #64  0x02bbfe28 in 0x2bbfe28
 #65  0x02bf6c24 in 0x2bf6c24
 #66  0x02befc58 in 0x2befc58
 #67  0x02bef938 in 
DoReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowStateR12
n
 #68  0x02bef5f8 in 
DoReflowInlineFramesAuto__12nsBlockFrameFR18nsBlockReflowState
 #69  0x02bef378 in 
ReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowState19nsLi
 #70  0x02bed578 in 
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_i
 #71  0x02becb34 in 0x2becb34
 #72  0x02beae3c in 0x2beae3c
 #73  0x02c13db8 in 
DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14n
s
 #74  0x02c13818 in 
ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18ns
C
 #75  0x02beecac in 0x2beecac
 #76  0x02bed19c in 0x2bed19c
 #77  0x02becb34 in 0x2becb34
 #78  0x02beae3c in 0x2beae3c
 #79  0x02b4691c in 
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR1
9
 #80  0x02cea2f4 in 
Reflow__11CanvasFrameFP14nsIPresContextR19nsHTMLReflowMetric
sR
 #81  0x02ca72a0 in 
Reflow__19nsBoxToBlockAdaptorFR16nsBoxLayoutStateP14nsIPresCon
 #82  0x02ca6c8c in 
DoLayout__19nsBoxToBlockAdaptorFR16nsBoxLayoutState
 #83  0x02ca181c in Layout__5nsBoxFR16nsBoxLayoutState
 #84  0x02cd35cc in 0x2cd35cc
 #85  0x02ca181c in Layout__5nsBoxFR16nsBoxLayoutState
 #86  0x02c620a4 in 
Reflow__10nsBoxFrameFP14nsIPresContextR19nsHTMLReflowMetrics
RC
 #87  0x02b4691c in 
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR1
9
 #88  0x02c31578 in 
Reflow__13ViewportFrameFP14nsIPresContextR19nsHTMLReflowMetric
 #89  0x02b5b3f8 in 
Dispatch__17IncrementalReflowFP14nsIPresContextR19nsHTMLReflow
 #90  0x02b6c40c in ProcessReflowCommands__9PresShellFi
 #91  0x02b6bdc4 in HandlePLEvent__FP11ReflowEvent
 #92  0x002ce070 in PL_HandleEvent
 #93  0x002cdedc in PL_ProcessPendingEvents
 #94  0x00274efc in ProcessPendingEvents__16nsEventQueueImplFv
 #95  0x01ed5c5c in 
ProcessPLEventQueue__26nsMacNSPREventQueueHandlerFv
 #96  0x01ed5b00 in 
RepeatAction__26nsMacNSPREventQueueHandlerFRC11EventRecord
 #97  0x01d40b14 in DoRepeaters__8RepeaterFRC11EventRecord
 #98  0x01eec218 in 
DispatchEvent__16nsMacMessagePumpFiP11EventRecord
 #99  0x01eebf40 in DoMessagePump__16nsMacMessagePumpFv
 #100 0x01eeb8bc in Run__10nsAppShellFv
 #101 0x01ea853c in Run__17nsAppShellServiceFv
 #102 0x001a400c in main1__FiPPcP11nsISupports
 #103 0x001a4a4c in main

Thread 1:
 #0   0x9000566c in syscall
 #1   0x90515d9c in BSD_waitevent
 #2   0x9051576c in CarbonSelectThreadFunc
 #3   0x90021268 in _pthread_body

Thread 2:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x9051dda0 in CarbonOperationThreadFunc
 #3   0x90021268 in _pthread_body

Thread 3:
 #0   0x90042ba8 in semaphore_timedwait_signal_trap
 #1   0x9003edd4 in _pthread_cond_wait
 #2   0x90233438 in TSWaitOnSemaphoreCommon
 #3   0x9023c258 in TimerThread
 #4   0x90021268 in _pthread_body

Thread 4:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x9023341c in TSWaitOnSemaphoreCommon
 #3   0x90248aec in _Z15AsyncFileThreadPv
 #4   0x90021268 in _pthread_body

Thread 5:
 #0   0x9003efc8 in semaphore_wait_signal_trap
 #1   0x9003ede4 in _pthread_cond_wait
 #2   0x90525b90 in CarbonInetOperThreadFunc
 #3   0x90021268 in _pthread_body

Thread 6:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x928ec28c in JNI_CreateJavaVM_Impl
 #3   0x928ec224 in JNI_CreateJavaVM_Impl
 #4   0x928a51fc in JVM_GetClassMethodsCount
 #5   0x90021268 in _pthread_body

Thread 7 Crashed:
 #0   0x929ba640 in eh_rest_world_r10
 #1   0x92857a38 in JVM_GetMethodIxLocalsCount
 #2   0x9285c128 in JVM_GetCPMethodNameUTF
 #3   0x928917f4 in JVM_MonitorNotifyAll
 #4   0x92886e6c in JVM_SetThreadPriority
 #5   0x92864964 in JVM_Send
 #6   0x9290114c in JNI_CreateJavaVM_Impl
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021268 in _pthread_body

Thread 8:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x05412668 in 0x5412668
 #7   0x0541068c in 0x541068c
 #8   0x0541068c in 0x541068c
 #9   0xa2843c38 in _ZTSSt13bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021268 in _pthread_body

Thread 9:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x05412668 in 0x5412668
 #7   0x0541068c in 0x541068c
 #8   0x054105cc in 0x54105cc
 #9   0x054105cc in 0x54105cc
 #10  0xa2843c38 in _ZTSSt13bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021268 in _pthread_body

Thread 10:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x92844e18 in JVM_GetClassLoader
 #4   0x92844ba4 in JVM_GetClassLoader
 #5   0x928a51fc in JVM_GetClassMethodsCount
 #6   0x90021268 in _pthread_body

Thread 11:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92903300 in JVM_InitProperties
 #5   0x92903138 in JVM_InitProperties
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021268 in _pthread_body

Thread 12:
 #0   0x90074168 in mach_msg_trap
 #1   0x900064b0 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x9288890c in JVM_StartThread
 #5   0x92876c10 in JVM_FindLoadedClass
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021268 in _pthread_body

PPC Thread State:
  srr0: 0x929ba640 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x92857a38  ctr: 0x928498e0   mq: 0x00000000
    r0: 0x00000030   r1: 0xf0386a40   r2: 0x92857a38   r3: 0x6c1631d8
    r4: 0x6c1631d8   r5: 0x6c163200   r6: 0x00000000   r7: 0x0000000c
    r8: 0xa2833a58   r9: 0x00000000  r10: 0x00000008  r11: 0x00000b18
   r12: 0x928498e0  r13: 0xa282bd1c  r14: 0x00000000  r15: 0xf0386b90
   r16: 0xa28320f8  r17: 0x00000000  r18: 0x00160000  r19: 0xa282bd1c
   r20: 0xf0386b60  r21: 0xa282bd1c  r22: 0xa282bd1c  r23: 0xa282bd1c
   r24: 0xbfffacdc  r25: 0x04597950  r26: 0x00000000  r27: 0x00000000
   r28: 0xa28305b0  r29: 0x04592b10  r30: 0x6c1631d8  r31: 0x9285bd1c



Reproducible: Sometimes

Steps to Reproduce:
1. just start browsing, try accessing more than one page at once...with 
different windows of course
2.
3.

Actual Results:  
shut down

Expected Results:  
not crashed

I was using the "breeze" theme at the time. i have had the same problem 
with the stock theme too. i have also seen this type of issue in IE 5

Comment 1

16 years ago
Upgrade to latest 1.2 build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.2

*** This bug has been marked as a duplicate of 154699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Browser-General → OJI
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.