Dual Monitors with FullScreen - lose Windows toolbar on screen without browser

VERIFIED DUPLICATE of bug 195963

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 195963
16 years ago
10 years ago

People

(Reporter: Dan Rollins, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Using Win98 or later. Dual video cards and monitors. Browser open fullscreen and
maximized on one monitor (a projector). The other monitor is used for general
use. The entire toolbar is invisable. I can hit the Windows key on the keyboard
and open the start menu but the taskbar remains hidden. I need the taskbar to
remain visable on the non-browser monitor.

Reproducible: Always

Steps to Reproduce:
1.open web page that calls another with the window.open script with
fullscreen=yes as well as attempting to remove borders and header
2.
3.

Actual Results:  
browser window opens with borders. Use ALT-B to move the browser window to the
other monitor. Taskbar is invisable.

Expected Results:  
Leave the taskbar on the first monitor desktop
(Reporter)

Comment 1

16 years ago
*** Bug 182559 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Pressing F11 to invoke fullscreen mode in a mozilla window moves that window to
the primary display and fullscreens there, rather than in the display that holds
the mozilla window.  Additionally, it assumes the resolution of the secondary
display.

Specifically, my laptop's build in display is at 1024x768 and is the secondary
display.  My task bar has been moved to the secondary display.  My external
1280x1024 monitor is my primary display.  This is set in the ATi control panel.

When I move the mozilla window to the secondary display, pressing F11 to invoke
fullscreen behaves as I expect.  When I move the mozilla window to the primary
display and press F11, it moves the window to the primary display, and sets the
window size to 1024x768 rather than 1280x1024 and does the other fullscreen
things that I expect.

Comment 3

16 years ago
dup of bug 127575?
Reporter: Do the two displays have the same resolution?

Comment 4

16 years ago
Duping of the bug that I asked burpmaster to file and include his research in.

*** This bug has been marked as a duplicate of 195963 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.