Crash after document.write, after an alert was opened, after it was called from setTimeout

RESOLVED DUPLICATE of bug 178810

Status

()

RESOLVED DUPLICATE of bug 178810
16 years ago
16 years ago

People

(Reporter: vladimire, Assigned: jst)

Tracking

({crash, testcase})

1.0 Branch
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Take a look at the testcase. To crash:
1) open up http://geckoqa.mcom.com/xml/res/XML_Tool_18nov_vlad.html
2) Wait several seconds, window will open, alert will come up
3) close alert. 
4) Reload main page - CRASH.

Talkback id 14374618
(Reporter)

Comment 1

16 years ago
Build is 2002-12-13-..-1.0
Also occurs on trunk builds, but there you dont even need to refresh the page,
just crashes after dismissing the alert. Trunk build: 2002112108 on WinNT4.0 (SP6)

Comment 2

16 years ago
Here is the stack trace for Talkback incident 14374618:

jsdom.dll + 0xbd4d (0x606fbd4d) 
jsdom.dll + 0x536a (0x606f536a) 
nspr4.dll + 0x82aa (0x60fc82aa) 
gkcontent.dll + 0x4508 (0x01af4508) 
jsdom.dll + 0x536a (0x606f536a) 


I crash on the testcase using Mozilla trunk 20021121xx on WinNT.
So this shows up on trunk as well as branch. I crash as soon as
I dismiss the alertbox (I don't have to reload the main page).

Tried to get a debug stack trace, but for some reason my debug
build will not even bring up the alertbox - perhaps the debug
asserts that come up are interfering with it - (?).

Without the alertbox from the testcase coming up, I don't have
a way to crash. So far, anyway -
Keywords: crash, testcase

Comment 3

16 years ago
Chances are this is a dup of bug 178810. At least its very similar. 
I could verify if you provide testcase that is accessible to me.

Comment 4

16 years ago
> Chances are this is a dup of bug 178810. 
Maybe not, description doesnt mention timeouts.

Comment 5

16 years ago
Here is Vlad's testcase:

<html><head><script language="javascript">

var i=0;
var  intvId="";
        
function attr()                 
{
    if(i < 1)
    {
      wnd=window.open("about:blank");
      setTimeout("uattr()", 2000);
      i++;
    }
    else
    {
      window.clearInterval(intvId);
      document.write(""); 
    }
}


function uattr()
{
   alert("Test");
   attr();
}

</script></head>
<body onLoad="intvId=setInterval('attr()', 4000)">
</body></html>

Comment 6

16 years ago
Yes, the crash was indeed similar to 178810.
Its now fixed, and I dont crash with the latest trunk. 

*** This bug has been marked as a duplicate of 178810 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.