When opening Mail, summary of inbox rebuilds itself and mark all messages as new

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: sancho, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020910

Sometimes, have no detailed explanation when, when I start mail, I get
rebuilding summary of Inbox. When this finish, I get almost all 832 messages
marked as new, sorting of messages is wrong (by date descending) and few (mostly
last day messages) are marked as they should.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Mail
2. Click on Inbox in first account
3.

Actual Results:  
Most of old messages are marked as new.

Expected Results:  
Leave the read status...

Updated

16 years ago
QA Contact: gayatri → esther
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
This bug is still there in Mozilla 1.3b on Linux.
(Assignee)

Comment 2

16 years ago
did you import your messages from another mail client? My guess is that they
have no x-mozilla-status lines. I'm not sure why your summary file gets rebuilt.
What kind of file system are you using? networked or local? How often does this
happen?

Comment 3

16 years ago
Yes, I imported my Outlook Express mail when I switched to Mozilla Mail. The
messages marked unread when the summary file is rebuilt are my imported
messages. Also, I share my message folder between Windows 2000 and Linux on a
local FAT32 partition.

Comment 4

16 years ago
On Linux i get this bug even though i've never imported mail from another
client. I have always used Mozilla mail. I have had this problem with recent
build of the last couple months, i think, and i still get it with the 1.4 build
from 2003-06-24. Could we change platform on this bug to "all"? 

Comment 5

16 years ago
By the way, the behavior i get is slightly different than that of the reporter.
For me, the summary rebuilds and the sort order is wrong, but i don't get
messages being remarked as new.

Comment 6

15 years ago
This sounds as if it's a duplicate of bug 207038.
Try the fix described in 207038.
If it works, then mark as duplicate of 207038.
Product: MailNews → Core
could very well be that dupe, unfortunately no one responded circa that time period.
=> WFM.  I haven't seen this in v1.5, 2.0 or trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.