Closed Bug 1819309 Opened 1 year ago Closed 1 year ago

Some RSS feed items are coloured black when selected instead of blue

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird111 --- fixed

People

(Reporter: AwesomeSheep48, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image Black RSS feed slection

In a few of my RSS folders, all of the messages – when selected – are coloured black instead of blue. This happens to all of the messages in the affected folder, but not all the folders in the same account.

Do you have "Automatically create tags from feed <category> names" enabled? You can find this in Subscribe... of the folder's context menu.

Yes, that is enabled in the folders which have this issue

Assuming it's the color of that tag then, and the items affected have got the tag?

William, can you give me the Feed address with the auto tagging? The feeds I have don't make the tags.

Flags: needinfo?(daviswill048)

(In reply to Richard Marti (:Paenglab) from comment #5)

William, can you give me the Feed address with the auto tagging? The feeds I have don't make the tags.

Here are a few which do this https://rss.cbc.ca/lineup/canada.xml, https://rss.cbc.ca/lineup/politics.xml, https://www.chch.com/category/news/feed/

Flags: needinfo?(daviswill048)

(In reply to Magnus Melin [:mkmelin] from comment #4)

Assuming it's the color of that tag then, and the items affected have got the tag?

I looked in settings just now, and yes, all the tags are set to be black; though I cannot remember it being like this until around a week ago, I still had "Automatically create tags from feed <category> names" enabled, but there was no colour change.

Geoff, this RSS autotags are a bit special. They don't have a colour set which ends in a empty --tag-color. This then makes TB use black as colour but the --tag-contrast-color is also set to black. Is it possible to give the --tag-color a colour (or maybe currentColor) when no colour is set?

You can test it also by removing a colour of an existing tag in prefs.js

Blocks: 1816295
Flags: needinfo?(geoff)
Keywords: regression

If we just don't add a rule for tags with no colour, the problem should go away, right? It works when I change the tag preferences.

Flags: needinfo?(geoff)
Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 112 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/9c3f6d8cb341
Don't create CSS rules for tags with no colour. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Attachment #9320724 - Flags: approval-comm-beta?

Comment on attachment 9320724 [details]
Bug 1819309 - Don't create CSS rules for tags with no colour. r=Paenglab

[Triage Comment]
Approved for beta

Attachment #9320724 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: