Closed Bug 1819604 Opened 3 months ago Closed 3 months ago

Message header panels like More button menu or Remote Content Preferences menu should have dark background with dark theme - macOS

Categories

(Thunderbird :: Theme, defect)

Thunderbird 112
Unspecified
macOS
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- fixed

People

(Reporter: NicolasWeb, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

(Keywords: ux-consistency, Whiteboard: [Supernova3p])

Attachments

(3 files, 1 obsolete file)

Steps to reproduce:

  1. Set dark theme on macOS version without system dark theme (in my case 10.13.6)
  2. Click on the More button on Message reader
  3. Click on Customize

Actual results:

It's all themed light

Expected results:

Dark theme should apply here too

Keywords: ux-consistency
OS: Unspecified → macOS
Whiteboard: [Supernova]
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

I just found that the same issue apply to the remote content warning bar button menu.

Richard, is your patch fixing this too please ? (or I report another bug)

Flags: needinfo?(richard.marti)

Comment on attachment 9320550 [details]
Bug 1819604 - Use white in thread pane for unread messages with dark themes. r=aleca

Revision D171353 was moved to bug 1819195. Setting attachment 9320550 [details] to obsolete.

Attachment #9320550 - Attachment is obsolete: true

Sorry, the patch wasn't for this bug.

The issue affects all panels. I'll create tomorrow a patch.

Flags: needinfo?(richard.marti)

Thanks for letting us know, Nicolas!

Severity: -- → S4
Summary: More button header should be black with dark theme - macOS → Panels like More button menu or Remote Content Preferences menu should have dark background with dark theme - macOS
Blocks: sn-msgreader
Summary: Panels like More button menu or Remote Content Preferences menu should have dark background with dark theme - macOS → Message header panels like More button menu or Remote Content Preferences menu should have dark background with dark theme - macOS
Target Milestone: --- → 112 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/66405ac2b380
Use layout variables for panels and menupopups inside the messageBrowser. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9320773 [details]
Bug 1819604 - Use layout variables for panels and menupopups inside the messageBrowser. r=aleca

[Approval Request Comment]
Regression caused by (bug #): [Supernova]
User impact if declined: popups in message header don't get the correct coloures on older macOS versions
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9320773 - Flags: approval-comm-beta?

Comment on attachment 9320773 [details]
Bug 1819604 - Use layout variables for panels and menupopups inside the messageBrowser. r=aleca

[Triage Comment]
Approved for beta

Attachment #9320773 - Flags: approval-comm-beta? → approval-comm-beta+
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.