Closed Bug 1819644 Opened 1 year ago Closed 1 year ago

after new update, the right click context menu appears behind the firefox, between the browser and my desktop display. It seems the fix for context menu in MacOS bring the bug to WIndow 11

Categories

(Core :: Layout, defect)

Firefox 110
Desktop
Windows 11
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: viethuy25, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/110.0

Steps to reproduce:

after auto update, I tried to right click the tab, not working. Right click in web page, not working too.

Actual results:

right click the tab, not working. Right click in web page, not working too.

Expected results:

bug fix for context menu for macOS somehow bring that bug to Window 11

Component: Untriaged → Widget: Cocoa
OS: Unspecified → macOS
Product: Firefox → Core
Hardware: Unspecified → Desktop

The OS is Windows 11, not MacOS. I refer to MacOS because the update notes say the bugs was from MacOS.

Summary: after new update, the right click context menu appears behind the firefox, between the browser and my desktop display. It seems the fix for context menu in MacOS bugs to WIndow 11 → after new update, the right click context menu appears behind the firefox, between the browser and my desktop display. It seems the fix for context menu in MacOS bring the bug to WIndow 11

Sorry.

Component: Widget: Cocoa → Widget: Win32
OS: macOS → Windows 11
Component: Widget: Win32 → Layout
Keywords: regression
Regressed by: 1763990

The code change in bug 1763990 was completely macOS-specific, with a tiny bit that could theoretically have affected Linux, but AFAICT nothing that even gets compiled on Windows.

Is this definitely a regression (ie it worked with 109) ? Can you perhaps use mozregression to find out what precisely broke it?

(I don't have windows 11 and on my Windows 10 machine I don't see this issue)

(Also, do you have XMBC installed by any chance?)

Flags: needinfo?(viethuy25)
No longer regressed by: 1763990

I dont have XMBC. Give me one sec, I'll try to download mozregression. It might have been windows 11 new update breaks too, since I noticed another bug outside of Firefox. Let me restart

Flags: needinfo?(viethuy25)

ok my bad, it seems like Windows 11 force bug on my laptop (which is up to date until 19 Feb 2023) to have a new update today. It breaks so many things. False flag. Sorry for the trouble

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.