Closed Bug 1819759 Opened 1 year ago Closed 1 year ago

Invitations can't be accepted from the summary dialog

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Thunderbird 111
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird111 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

Details

(Keywords: regression)

Attachments

(1 file)

Clicking on the accept button triggers this error:

Uncaught (in promise) ReferenceError: ensureCalendarVisible is not defined
    doTransaction chrome://calendar/content/calendar-item-editing.js:673
    onModifyItem chrome://calendar/content/calendar-item-editing.js:400
    onInvitationDialogAccept chrome://calendar/content/calendar-summary-dialog.js:259

I can't work out when or why this broke. I'll just fix it, I guess.

The failure case is trying to call ensureCalendarVisible from an about:message window. Call it from the topmost window instead. In other cases this will change nothing.

Assignee: nobody → geoff
Status: NEW → ASSIGNED

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/b3e7bdfcd50b
Call ensureCalendarVisible from the right context. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch

Comment on attachment 9320664 [details]
Bug 1819759 - Call ensureCalendarVisible from the right context. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): supernova

Attachment #9320664 - Flags: approval-comm-beta?

Comment on attachment 9320664 [details]
Bug 1819759 - Call ensureCalendarVisible from the right context. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9320664 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: