Blinking cursor ghosts after Hide/Show Toolbar

RESOLVED DUPLICATE of bug 207210

Status

RESOLVED DUPLICATE of bug 207210
16 years ago
13 years ago

People

(Reporter: stf, Assigned: bryner)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021125 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021125 Chimera/0.6+

Type some text in a form field, like Details in this bug report.
Hide the Toolbar
You'll get a ghost that will remain there, shifter.
Use arrow keys, it will move shifted too.

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
Confirmed in the 2002-11-25-04 NB.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Still true with build id 2003082402.
Same issue, though not related to switching tabs.

*** This bug has been marked as a duplicate of 188517 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
Reestablishing the distinction between bug 207210 and bug 188517.  See bug
207210 comment 5.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 207210 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
The problem here is really closer to bug 306173, but it's unique in that no tab switching is required at all.  Presumably the caret cleanup going on for Gecko 1.9 will fix all of these issues.

Comment 7

13 years ago
Maybe I misunderstood what was meant by "blinking cursor ghosts".  But I assumed it was just another way of reproducing bug 207210 or something similar.  But this reproduction method seems to be either intermittent or Camino-specific - at the moment in SeaMonkey 2005101209, I can't seem to reproduce it.

Does the ghost blink or not?  Does anything blink on the screen, and in the right place or the wrong place?  What is meant exactly by "it will move shifted"?
Created attachment 201227 [details]
Aftermath of hiding Camino toolbar

The original text (and caret, now static) move with the page content and stay at the top of the textarea, but the caret remains in the same position on the screen where it was before hidig the toolbar.  It's a live, blinking caret, and you can move it to the left as if you were arrowing back through the text (leaving a second ghost, static caret).  A destructive operation fixes things, though.

I couldn't reproduce this in Fx 1.5RC1, and I'm more and more convinced this is probably a Camino-only/embedding-specific bug/behavior.
You need to log in before you can comment on or make changes to this bug.