Closed Bug 181988 Opened 17 years ago Closed 15 years ago

Prefill "create filter from message" to include "to", "cc" and "subject"

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 199274

People

(Reporter: Joerg.Thoennes, Assigned: sspitzer)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

If I receive the first messages from a mailing list and I want to filter it,
currently I have to open the "Create message filters" dialog and copy all values
from this messages. A really helpful feature would be if a popup-meny entry
as "Filter this message" or "Generate filter from this message" would exist, which
opens the "Create message filters" dialog and fills in all fields from this
message. Then the user could generalize this message by deleting distinct entries,
shortening string and changing from exact match to e.g. match begining etc.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
What "all fields" are you filtering on? 

We do have "Create Filter from Message" currently for the From header, available
as a pop-up from the header display or Message menu.  

There is already a bug about having the prefilled info in filter dialog work for
To: CC:, etc.  But we don't have plans (or existing bug) to prefill all headers
from a given message into a filter.
> We do have "Create Filter from Message" currently for the From header, available
> as a pop-up from the header display or Message menu.  

I did not knew this entry. I expected to this see this entry in the message
overview per-message pop-up.

> There is already a bug about having the prefilled info in filter dialog work 
> for To: CC:, etc.  But we don't have plans (or existing bug) to prefill all 
> headers from a given message into a filter.

The following fields I would expect in addition to the From: field:

    To: Cc: Subject:

It is easier (faster) to delete or edit pre-filled fields than to enter possibly
complicated strings.
> It is easier (faster) to delete or edit pre-filled fields than to enter 
> possibly complicated strings.

However, it is likely that "subject" will hardly ever be the same in between
messages and that you will almost never care about "cc", so that for every time
that you're glad the string was prefilled, there would be many more times when
you'd be deleting it.

As such I recommend WONTFIX (though some real usage data on how this feature is
used would be nice), but for now am confirming it as a valid RFE.

related bug 106518 is for having "to" filled in instead of "from" when clicking
on that email address in the header.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RFE] Add "Filter message" to popup-menu for messages in the message overview → Extend "create filter from message" to include "to", "cc" and "subject"
Also see bug 199274, which asks for a way to quickly add _any_ header from the
original message, without filling them in beforehand (which would be somewhat
more useful than this request).
mass re-assign.
Assignee: naving → sspitzer
*** Bug 200604 has been marked as a duplicate of this bug. ***
*** Bug 219196 has been marked as a duplicate of this bug. ***
Blocks: 66425
Product: MailNews → Core

*** This bug has been marked as a duplicate of 199274 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Summary: Extend "create filter from message" to include "to", "cc" and "subject" → Prefill "create filter from message" to include "to", "cc" and "subject"
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.