If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser tried to open web page instead of search

RESOLVED DUPLICATE of bug 135363

Status

SeaMonkey
Location Bar
--
minor
RESOLVED DUPLICATE of bug 135363
15 years ago
9 years ago

People

(Reporter: Assaf Lavie, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

After typing a "non-url" into the url box I get: "the URL is not valid... " 
this is fine. So I go back to the URl box (focus on it with f6) and press
key-down to move to the option: "Search google for my non-url". But I get the
same "the url is not valid" message again. In order to correct it I have to
retype some part of the URL (any part, even delete and re-type the last letter)
and then press the down-key -> select the "search google .. " line and enter.
only _then _ will it work.
The browser is configured to use Google.com as the search engine of choice.

Reproducible: Always

Steps to Reproduce:
1. type: "my non url" in the url box.
2. click ok on the "not a valid URL ... " message box.
3. press f6 -> press the down key and select "search google for: my non url"
4. press enter

Actual Results:  
mozilla tries to resolve the URL.

Expected Results:  
Is should search for the string on Google.

The browser is configured to use Google as it's search engine.

Comment 1

15 years ago
Reproduced on WinXP SP3, 2002112405.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 135363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.