Installer names for XP mail/internet/HTML Editor clients should be consistent

VERIFIED DUPLICATE of bug 169159

Status

SeaMonkey
Installer
--
trivial
VERIFIED DUPLICATE of bug 169159
15 years ago
13 years ago

People

(Reporter: James Nord, Assigned: dveditz)

Tracking

({polish})

Trunk
x86
Windows XP
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021121

When you install Mozilla on Windows XP it can act as the default handler for
internet shortcuts and mail.

However the client naming is not consistent.

Mail is called "Mozilla 1.2 Mail"
Internet is called "Mozilla"
HTML Editor is called "Mozilla"

They should either all contain the version string or neither (I would prefer
neither.)

ie. currently Internet uses:
   winreg.setValueString(subkey, "", "$ProductNameInternal$");
Mail uses
    winreg.setValueString(subkey, "", "$ProductName$ Mail");
HTML Editor uses??
    I presume XP grabs this from the executable versioning info (but it works
out at "Mozilla" in any case)

http://lxr.mozilla.org/seamonkey/source/xpinstall/packager/windows/mail.jst#226
http://lxr.mozilla.org/seamonkey/source/xpinstall/packager/windows/browser.jst#307


They should all use the same string.  ($ProductNameNoVersion$ ?)
(Assignee)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 169159 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.