Prefs->Privacy->History should offer to clear download manager

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Philip White, Assigned: Blake Ross)

Tracking

({privacy})

Trunk
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

16 years ago
I recently realized that pressing the two buttons in preferences to clear the
history and the location bar is not enough to clear your tracks -- you also have
to open the download manager and manually clear your downloads.

The preferences window should have the option to clear Download Manager's
history with the press of a button -- otherwise it's a privacy issue.  This is
an enhancement, but because of privacy issues I'm nominating it a minor severity.

Comment 1

16 years ago
Bug 132755 is about various preferences concerning the download history.
Bug 132755 comment #37 and #43 also mention what this bug is about.
So this bug is not exactly a duplicate, but might be fixed by that other bug.

Comment 2

15 years ago
I agree with this and would go further.  Records of past downloads are part of
the browsing history.  Clearing the navigation history should clear the download
history as well, by default.  I don't even see any need for an option to NOT
clear the download history when the navigation history is cleared, but if people
want such an option, I guess it's ok.
(Reporter)

Comment 3

15 years ago
I am bumping the severity because, first, the user doesn't even KNOW that their
downloads are logged unless they know about the Download Manager, and second, a
history of downloads can be much more harmful than a history of visited websites
-- there's no excuse that it was an accidental visit.

It's critical that the download list can be cleared without jumping through hoops...
Severity: minor → major

Comment 4

15 years ago
Enhancement
Severity: major → enhancement
(Reporter)

Comment 5

14 years ago
Since Firefox now offers the option of clearing the download list once per
session or even immediately after each download, I think that this enhancement
is unnecessary.

However, because it already has one vote, I won't be too hasty with resolving it
invalid.  If anyone shares my opinion, please close this bug.  (Or let me know,
and I'll close it.)

Comment 6

14 years ago
Philip, please don't confuse Firefox bugs with Browser/Suite/Seamonkey bugs. 
Ok, you are the reporter in this case, but if you resolved it, someone else
would have to file an identical bug...
(Reporter)

Comment 7

14 years ago
Ah, my mindset has already been fully Firefoxized.  Sorry.  We'll keep this bug
open until someone picks it up or refuses it.

Comment 8

14 years ago
Following up on a discussion in bug 141998, is this a request for the "CLEAR
ALL" feature in the suite [similar to firefox] or for the CLEAR DOWNLOAD MANAGER
HISTORY feature from firefox.

According to comment 0 i would guess the latter, and that would mean that this
bug and bug 141998 aren't dupes of each other, but that this request is asking
for a superbutton clearing ALL user tracks in a single sweep. Please confirm if
that interpretation is correct and [we'll] adapt the summary accordingly.
(Reporter)

Comment 9

14 years ago
Yes, it is the latter.  I request a button to clear download manager history,
which would then be tied to the "Clear All" button of Firefox.  The Mozilla
suite is not relevant to this bug, although it would be good if it had the same
functionality.

Comment 10

14 years ago
(In reply to comment #9)
> The Mozilla suite is not relevant to this bug

Philip:
May I remind you of comment #6?
This bug is not filed under the Firefox component and no Firefox developer will
look at it.
The fact that its assignee is Blake and its email adress includes "firefox"
means nothing. It's like that because he once wrote the (suite!) download
manager and therefore was default assignee for download manager bugs when you
filed this bug.
(Reporter)

Comment 11

14 years ago
Refiled.  Sorry for the confusion.
Component: Download Manager → Download Manager
Product: Browser → Firefox

Comment 12

14 years ago
Philip, shouldn't you update the summary then as well?
(Reporter)

Comment 13

14 years ago
Sure.
Summary: Navigator->History should offer to clear download manager → Prefs->Privacy->History should offer to clear download manager

Comment 14

13 years ago
*** Bug 241777 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
Created attachment 203638 [details]
Pref/Privacy window screenshot

Comment 16

13 years ago
sorry... I attached this to the wrong bug... not sure how to (or if I can) delete it. Will be more careful next time.

Updated

13 years ago
Attachment #203638 - Attachment is obsolete: true
Time to put a stake in this massively morphed bug's heart: comment 0 wanted a one stop place to clear history and download history, and we've got that in Clear Private Data. If, while looking at the current state of things in either Firefox 2a1 or Firefox trunk, someone still thinks that the Privacy tabs for History and Download History should be combined, they're welcome to file a new and narrowly focused enhancement bug on just that, though I suspect it would be wontfixed since Clear Private Data already meets the need.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.