Closed Bug 1820721 Opened 1 year ago Closed 1 year ago

Message pane doesn't update after delete in some circumstances

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(thunderbird111 affected)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird111 --- affected

People

(Reporter: darktrojan, Assigned: darktrojan, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When a message is deleted, the next message should load in the message pane. Usually this does work, but after archiving a message and then deleting a message, the message pane doesn't get updated. I think that the thread tree is not firing a "select" event when the selection changes, because the deleted message had the same index as the next message now has.

I can no longer reproduce this, but Ryan says it's still happening.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6353f61ca7b8
Ensure a "select" event is fired from the thread tree after message deletion. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Ryan, does this still fail for you? Beta 112 or Daily 113?

I think we have some users report this is still happening

Flags: needinfo?(ryan)
You need to log in before you can comment on or make changes to this bug.