Open Bug 1820797 Opened 1 year ago Updated 6 months ago

Address bar drop-down flickers if maxRichResults pref is set to 0

Categories

(Firefox :: Address Bar, defect, P5)

Desktop
All
defect

Tracking

()

Tracking Status
firefox110 --- wontfix
firefox111 --- wontfix
firefox112 --- wontfix

People

(Reporter: cbaica, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Attached video address bar flicker

Found in

  • Fx 112.0a1

Affected versions

  • Fx 112.0a1
  • Fx 111.0

Affected platforms

  • all

Steps to reproduce

  1. Launch Firefox.
  2. Go to about:config and set browser.urlbar.maxRichResults to 0.
  3. Open a new tab and click inside the address bar.

Expected result

  • Nothing happens and text input indicator is correctly displayed for the address bar.

Actual result

  • The address bar flickers, displaying for a brief time the topsites(shortcuts).

Regression range

  • Looking into a regression is proving difficult, as none of the builds downloaded by the tool exhibit this issue. Will try and narrow it down manually if necessary.

Additional notes

  • Please note that this issue occurs if the user inputs some text and then clicks the address bar. In this case, the flicker only displays the search engines from the bottom of the 'regular' address bar dropdown.
  • In Fx 103.0a1 only this last part of the issue occurs (the one described in notes), not the one described in the steps - meaning that clicking the address bar with no input, does not cause the entire address bar drop-down to be briefly displayed.
Has STR: --- → yes

I was able to manually narrow this down manually to this push https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=844e77bdce07d0a48357cd4035683b89ddd5fbdc. (bug 1782038 or bug 1767695) Even though both bugs are open, they landed fixes in Fx105.

Flags: needinfo?(jdescottes)

That regression window seems odd. One patch is test only, the other one is almost test only, and the non-test file which was modified is not loaded in the STRs

FWIW I can't reproduce the main issue on a local build or on Nightly/devedition/release/esr. The second issue (flicker after adding some text in the url bar) seems to happen already in ESR 102.

Flags: needinfo?(jdescottes)

Ah I managed to reproduce, but it's important to trigger the URL bar suggestions first, before reducing browser.urlbar.maxRichResults to 0. Might be related to some caching.

So for me the STRs are:

  • open a new tab
  • click on the URL bar to display suggestions
  • open about:config
  • set browser.urlbar.maxRichResults to 0
  • open another tab
  • click on the URL bar

-> The suggestions will flicker. This also affects ESR (102) so I think this is not related to the DevTools bugs mentioned above.

Youre right, my apologies. I re-ran it and it actually is broken in the previous push as well. I will try again following the new STR

QA Whiteboard: [qa-regression-triage]

I have managed to reproduce this issue in all the main channels and also in a late nightlies launched by mozregression.
Unfortunately, this regression could not be completed because the builds are too old for mozregression to dig deeper.

Tested mozilla-central build: 2022-01-03 (verdict: b)
Tested mozilla-central build: 2022-01-02 (verdict: g)

This investigation was performed on a Windows 10.

QA Whiteboard: [qa-regression-triage]

This will no longer be an issue if we take a different approach to the one-off buttons.

Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: