IPv6: support in 1.2b under Windows 2000

VERIFIED DUPLICATE of bug 110565

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 110565
15 years ago
15 years ago

People

(Reporter: Rejo Zenger, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

There is no IPv6 support in 1.2b under Windows 2000. If the server supports both
IPv6 and IPv4, Mozilla will connect by IPv4. If the server supports IPv6 only,
it errors with the usual "server not found" messages. Using MSIE those sites to
work.

I guess the problem is a bug in the way Mozilla looks up the AAAA record. It
fails, and will take the A record if the server has one or will completly fail
if the server has no A record.

See http://www.ipv6.bieringer.de for a site with only an AAAA record and
http://ipv6.aerasec.de/ for a site that supports both IPv6 and IPv4. The latter
one will tell you, you are connected by IPv4 while Mozilla should have connected
with IPv6.

Reproducible: Always

Steps to Reproduce:
1. Just try to load http://www.ipv6.bieringer.de under the Windows 2000 with
Mozilla 1.2b.

Actual Results:  
Mozilla will produce a "server not found" error. It will not find the AAAA
record for that server.

Expected Results:  
Connect by IPv6 and render the page.

Because of the importance of IPv6 in future, I think this should be fixed.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 110565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Are you saying that mozilla queries for a AAAA record (and fails to process the
response correctly) -or- that Mozilla for Win does not query for AAAA at all
(and hence fails w/ your first example, but makes an IPv4 connection w/ your
second example)?

(I was not entirely clear based on the information you provided.)

Comment 3

15 years ago
benc: mozilla for w32 doesn't query for aaaa's according to the other bug :(
Status: RESOLVED → VERIFIED

Updated

15 years ago
QA Contact: benc → ipv6
Summary: There is no IPv6 support in 1.2b under Windows 2000 → IPv6: support in 1.2b under Windows 2000
You need to log in before you can comment on or make changes to this bug.