Opening mail client causes mozilla to crash.

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Glenn Meyer, Assigned: racham)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.3a) Gecko/20021123
Build Identifier: Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.3a) Gecko/20021123

When I open Mail & News, either from the Window menu or from command-line startup, 
mozilla crashes, and the following message is issued: 

the addressbook migrator is only in the commercial builds.
rld_sbrk: Can't open /dev/zero


Reproducible: Always

Steps to Reproduce:
1.Start Mail & News, either from Window menu or from command line.

Actual Results:  
Mozilla crashed, and the following diagnostics were output

> the addressbook migrator is only in the commercial builds.
> rld_sbrk: Can't open /dev/zero


Expected Results:  
Run without crashing. 


IRIX64 brian 6.5 07121149 IP30

Versions: 
I  fw_gtk+              10/29/2001  gtk+-1.2.10 GIMP Toolkit

xdpyinfo:
name of display:    :0.0
version number:    11.0
vendor string:    Silicon Graphics
vendor release number:    6600
maximum request size:  262140 bytes
motion buffer size:  0
bitmap unit, bit order, padding:    32, MSBFirst, 32
image byte order:    MSBFirst
number of supported pixmap formats:    6
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 12, bits_per_pixel 16, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 30, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 15, maximum 149
focus:  window 0x3c0000e, revert to PointerRoot
number of extensions:    31
    Adobe-DPS-Extension
    DCShare
    DEC-XTRAP
    DOUBLE-BUFFER
    DPMS
    DPSExtension
    ESA
    Extended-Visual-Information
    GLX
    LBX
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    READDISPLAY
    RECORD
    ReadDisplay
    SCREEN-SAVER
    SGI-NewMultibuffering
    SGI-SCREEN-CAPTURE
    SGI-SUNDRY-NONSTANDARD
    SGI-VIDEO-CONTROL
    SGIFullScreenStereo
    SHAPE
    SYNC
    TOG-CUP
    XC-APPGROUP
    XC-MISC
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1280x1024 pixels (364x291 millimeters)
  resolution:    89x89 dots per inch
  depths (6):    1, 8, 12, 15, 24, 30
  root window id:    0x4c
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 29
  default colormap:    0x49
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 7
  options:    backing-store NO, save-unders NO
  largest cursor:    32x32
  current input event mask:    0x72203c
    ButtonPressMask          ButtonReleaseMask        EnterWindowMask          
    LeaveWindowMask          ButtonMotionMask         StructureNotifyMask      
    SubstructureRedirectMask FocusChangeMask          PropertyChangeMask       
  number of visuals:    41
  default visual id:  0x20
Reporter:
Have you write access for /dev/zero ?
Summary: Opening mail client causes mozilla to crash. → Opening mail client causes mozilla to crash.
(Reporter)

Comment 2

16 years ago
Yes, /dev/zero is writable by all: 

> ls -l /dev/zero
crw-rw-rw-    1 root     sys        37,  0 Nov 15 10:28 /dev/zero

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 3

16 years ago
Okay, the latest build, as of 11/29/02, lets me start up Mail&News, but 
now when I try to send a message, as often as not, mozilla crashes. There's
no core dump, no message is sent, and nothing is copied to the record file.
And mozilla doesn't always crash at this point, but it does more than half 
the time. Also, when I attempt to open the following link from Mail&News, 
mozilla crashes every time. 

http://digilander.libero.it/caricacell/

I don't suppose there's a Talkback enabled build of Mozilla that I can 
use instead of the one I'm using? 

Comment 4

16 years ago
I found descriptions that possibly mean the same bug at #142615; #181911

I have mozilla 1.2.1 installed at a Windows98 SE System. It's a PC with a
Petnium 133 and 96 MB Ram.

I use the Software 'KEN' by AVM what allows all PC's in my network to access the
internet over one ISDN Adapter. Ken also works as a mailserver.

I use POP3.

I have installed Mozilla. Then I set up 1 Mail account. After that I fetched
Email for this Account and it worked. 

Then I imported the mail from Outlook Express.

I set up 2 other accounts an tried to fetch all mail with 'strg+shift+t' It
doesn't work - only the mail for the 'highlitghtet' account was fetched. So I
got the mail for the three accounts - one after the other. Then I imported the
Outlook Express Address book. This was done succesfully.

Then I tried again to fetch all mail with 'strg+shift+t'. Mozilla crashed. I
killed the Task and started Mozilla again. Mozilla was working until I tried to
open the 'mail' window. Then it crashed. I had always to kill the task. 

I restarted the computer but the 'mail' crashed mozilla.

I installed mozilla again - but the crash while opening 'mail' remained. I
started the profile manager and created a new profile. With the new profile
mozilla works sufficiently (until now with one account). As soon as I use the
old profile mozilla crashes trying to open 'mail'. 

It seem to me that the program hangs while it tries to fetch mail from the 'Ken
mailserver' and blocks all Mozilla activity. (When I open the Windows Task
Manager after reproducing the crash the 'Mozilla-Item' has the hint 'reagiert
nicht' what means doesn't react.

Do you know, how I can get the Mails from the crashed profile???


Stefan Schäfer stepfahn@gmx.net

Comment 5

16 years ago
I replaced the XUL.mfl file by another version of it, generated in the new
profile I set up - and suddenly I can use the mail client as desired. By the
way, before that I replaced all files in the 'profiles' folder - but with this
one it worked.
I tried to upload the crash provoking file - but I were not successful. If you
giv me an email address, I can send you the 800 Kbyte zip.
Stefan:
a) You mean a hang/freeze but not a crash. That is very different.
b) Don't hijack other bugs with are very different
c) You can easy delete xul.mfl while mozilla is not running. It will be recreated
d) You mean a known other bug. (search with xul.mfl in the summary to find it)

Glenn: Sorry but i can't help here since i know near nothing about SGI :-(
AFAIK it's a known problem for *nix that mozilla doesn't generate a core dump
after a crash.
Talkback is only availible for Linux, win32, Mac classic because Talkback is a
commercial software. 
The main problem : I really don't know anyone here @ bugzilla that works on SGI/IRIX

Comment 7

15 years ago
Glenn: Do you still see this bug with some current Mozilla build?
Product: Browser → Seamonkey

Comment 8

14 years ago
Glenn: Do you still see this bug with a current Mozilla build?
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
> Glenn: Do you still see this bug with a current Mozilla build?

No, although I see a similar problem with Thunderbird 1.0 in Mac OS X. In fact,
I am unable to run Thunderbird on Mac OS 10.3.8. The program opens, but it hangs
when it reaches the stage of opening the Inbox. Anyway, I would say that this
bug is irrelevant: There haven't been any releases of Mozilla on IRIX lately,
that I know of. 

Glenn
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.