[mach-o] FizzillaMach will not start up when path to application includes a space character

RESOLVED DUPLICATE of bug 183366

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 183366
15 years ago
13 years ago

People

(Reporter: Paul Bergsagel, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021125
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021125

I am unable to launch the Mach-O build of Mozilla. Upon lauch the Mozilla icon
bounces several times in the dock. The icon disappears from the Dock. There are
no error windows or symptoms of a crash or freeze.

Reproducible: Always

Steps to Reproduce:
1.Install Mach-O Mozilla
2.Launch application

Actual Results:  
The Mach-O icon bounces several times, then disappears. This is not a freeze or
a crash. My best description is that Mach-O Mozilla attempted to launch but quit
after a few icon bounces in the Dock without leaving behind a Dock icon or
evidence of a freeze or crash.

Expected Results:  
Application would launch as expected.

I an using a B/W G3-350 with 256 meg MacOS X 10.1.5 

Does Mach-O require 10.2 by any chance?

I am able to run the CFM build perfectly.
(Reporter)

Comment 1

15 years ago
My appologies: I forgot to include the Mach-O Mozilla build. It was the Mach-O
nightly from 11/26/02.
Whiteboard: Mach-O

Comment 2

15 years ago
Paul, is this a problem with your profile, possibly? Try launching FizzillaMach
from the command line with the -ProfileManager argument and make a new profile.

Mozilla.app/Contents/MacOS/mozilla-bin -ProfileManager

Updated

15 years ago
URL: n.a.
Severity: blocker → critical
Summary: Mach-O Mozilla fails to launch. → [mach-o] Mach-o Mozilla fails to launch
Whiteboard: Mach-O
(Reporter)

Comment 3

15 years ago
Marking this bug as invalid. See comment 2. Following Greg's instructions I
lauched Macho Mozilla from the command line and using the profile manager
located my profile and now Mozilla works as expected. Thanks Greg for your
assisatnce! :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
Paul, the bug isn't invalid just because you could start it using another
profile, it just means there is something about your other profile that
FizzillaMach doesn't like. We need to determine what that is.

Did you have a third-party theme installed? Try moving the chrome.rdf file out
of the profile's chrome directory and starting FizzillaMach. You could also try
moving localstore.rdf out of the profile temporarily and see if it starts.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 5

15 years ago
Greg,

I believe this bug is invalid. Here is why I say this. When I started up the app
with the command line this brought up the profile manager which allowed me to
select my profile created with the CFM version of Mozilla. This allowed Mozilla
to recogonize my CFM profile. I did not create a new profile with Mach-O. I
still claim my bug is invalid. 

I am marking this bug as invalid. It has nothing to do with anything wrong with
my CFM profile. Mach-O recognizes the CFM profile. I simply need to know what to
type into the command line.

Now this bug might be changed to "Mach-O Mozilla needs a way to access/launch
the profile manager other than by way of the command line." My original bug is
invalid. I am now using my profile which I created with the CFM version with the
Mach-O version unchanged. It works. I simply needed a way to launch the profile
manager and select a profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 6

15 years ago
Paul, not true. If you have to use the command line to get FizzillaMach to use
your CFM-created profile, there is a problem and we need to figure out what it is.

The issue of accessing the Profile Manager some way other than the command line
is another problem that requires a separate bug (if one isn't already filed, but
I think it is).

Please don't resolve this bug again until someone says to, or determine this is
a dup of another already-filed bug. Bugzilla isn't about getting Mozilla to work
for you, it's about figuring out why Mozilla does something wrong.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: [mach-o] Mach-o Mozilla fails to launch → [mach-o] FizzillaMach will only load CFM-created profile when launched from command line

Comment 7

15 years ago
Paul, there is one reason why you might close this bug, and that is if you're
unwilling to participate in investigating why FizzillaMach behaves this way for
you. If you're unwilling to participate, there's little hope of pursuing the
matter, and in that case feel free to close the bug.

Comment 8

15 years ago
I experienced the same problem with the most recent (11/26) MachO build. The
icon bounces a bit then quits. The Console shows this message:

Usage: apprunner <url>
	<url>:  a fully defined url string like http:// etc..

Yes, it does start up if I use the terminal command that Greg gave. As a test I
moved all my profiles out of ~/Library/Mozilla and tried to launch from the icon
again - no dice.

I started a 10/23 build of FizzillaMach from the icon and it worked fine.
Machine: Powerbook/1Ghz, OS 10.2.2

The CFM profile thing may be a red herring.

Comment 9

15 years ago
Hm, WorksForMe using FizzillaMach/2002112607. I tested both using my main
profile in my main OS X user account, and in a fresh OS X account with no
Mozilla profile, and it started just fine.

Kevin, can you try testing using a fresh OS X user profile like I did and see if
it works?

Comment 10

15 years ago
Strange. I found that it worked when I created a new user and ran FizillaMach.
Then I realized I had renamed the .app bundle to "Mozilla 11/26" as I always do
when testing builds. I found that Mozilla failed as described above when I
renamed the .app bundle to have a space in the name. If I renamed it
"Mozilla11/26", it launched perfectly. Can you try this Greg?

Comment 11

15 years ago
I'll try that when I get a chance.

Paul, did you do anything like that, renaming the application?
(Reporter)

Comment 12

15 years ago
Greg,

Sorry for miscommunication. I was under the impression that you thought I had
created a fresh profile to get Mach-O to work. I did not. I am using my
pre-Mach-O profile.

The issue I originally had was that Mach-O failed as it launched. If there was
easy access to the profile manager, wouldn't this resolve the bug? It appears to
correct whatever issue there is with Mach-O recognizing the pre-Mach-O profile.
If you still disagree the bug is not resolved I will check my profile for
issues. I will require some suggestions as to what to look for. I want to
provide any help to resolve this bug amd may be mistakenly under the impression
that launching the profile manager corrects the problem.
(Reporter)

Comment 13

15 years ago
Greg,

Before using the Mach-O build, I alaways installed a new mightly in a folder
called "Latest Mozilla Nightly" so all users on the computer not loose their
path to this build and still launch the new build.

I used this same procedure when I installed Mach-O. Mach-O Mozilla was installed
on a partition I usually install apps and documents on in a folder titled
"Mach-oNightly." I did not change the name of the Mozilla application(mach-O). I
keep OS X on its own partition by itself. 

Is it possible the Mach-O build expects to be installed on the same Volume with
OS X or if it is placed in a folder with another name than the expected name the
application is unable to locate the user's profile and quits.  I suspect that
when Mozilla was launched it failed to locate the profile and quit. When this
situation occurs with the CFM and Mac Classic builds Mozilla would automatically
launch the profile manager and could locate the profile for Mozilla. If Macho
Mozilla would automatically launch the profile manager when if failed to locate
a profile, this bug would be resolved. Thus with this theory one must accept
that the CFM profile is fully compatible with the Mach-O build.

This is my untested theory. How do you think if fits with the description of the
bug Greg?
(Reporter)

Comment 14

15 years ago
I believe bug 183366 is a duplicate of this bug.

Comment 15

15 years ago
Confirmed using FizzillaMach/2002120907 per Gerich's comment 10. FizzillaMach
will not launch when the path to the application includes any space characters
(whether in the application name or an enclosing folder).

(Paul, your comment 13 is corroboration, since you put the application in a
folder whose name includes space characters.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [mach-o] FizzillaMach will only load CFM-created profile when launched from command line → [mach-o] FizzillaMach will not start up when path to application includes a space character
(Reporter)

Comment 16

15 years ago
Greg,

I made a mistake when I mentioned the name for the folder I put Mozilla in. I
just checked and I had it in a folder titled "Mach-oNightly" no spaces. The
volume the folder is on also titlted "NewDrive15" also containes no spaces. 

My CFM build is on the same volume titled "Mozilla Latest Trunk" does contain
spaces. But I did not put the Mach-O build in this folder.

Spaces may be an issue, but since all of the path names leading to the Macho
build does not contain any spaces. There is another issue as to why the Macho
build fails to locatemy profile.  My profile is also on the same volume as
Mozilla titled "PaulMozillaProfile" with no spaces.


*** This bug has been marked as a duplicate of 183366 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 18

15 years ago
Paul, retest using a 20021210 or later FizzillaMach build and ensure that bug
183366's fix cures the problem for you.
(Reporter)

Comment 19

15 years ago
Greg,

The bug appears fixed:) With my last post I simply wanted to clear up my
mistakes with naming folders in case you felt my post confirmed the the bug was
due to spaces. I believe the bug is fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.