Crashes on load with GTK2

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: stephen, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2b/src/mozilla-source-1.2b.tar.gz

Mozilla compiles fine with the GTK2 patch, but when I try to load Mozilla, I 
get this error message repeated over and over.

Gdk-CRITICAL **: file gdkimage-x11.c: line 700 (gdk_image_get_pixel): assertion 
`x < 0 || x >= image->width' failed

Reproducible: Always

Steps to Reproduce:
1.  Configure Mozilla with ./configure --prefix=/usr/local --enable-default-
toolkit=gtk2 --disable-debug --enable-xft
2.  Build.
3.  Run.

Actual Results:  
I get the error message:
(<unknown>:10386): Gdk-CRITICAL **: file gdkimage-x11.c: line 700 
(gdk_image_get_pixel): assertion `x < 0 || x >= image->width' failed

Expected Results:  
Loaded up and displayed a window.

Built with Debian sarge/sid and GARNOME.

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
can you get a stack from gdb?  you might try a recent trunk build, gtk2 code has
changed quite a bit since 1.2b.

==> blizzard
Assignee: asa → blizzard
(Reporter)

Comment 2

16 years ago
Hmmm... the problem has abruptly gone away.  Oh well, thanks anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.