Closed Bug 1821574 Opened 1 year ago Closed 1 year ago

Two pixel gap between Spaces Toolbar and Folder Pane with > 100% display scaling on Linux

Categories

(Thunderbird :: Theme, defect)

Thunderbird 111
Unspecified
All
defect

Tracking

(thunderbird111 wontfix, thunderbird115? fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird111 --- wontfix
thunderbird115 ? fixed

People

(Reporter: bugzilla.mozilla.org, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

Attached image Spaces-Folders-Gap.png

Steps to reproduce:

Close and re-open Spaces toolbar.
I'm on Linux Plasma desktop with Thunderbird 111.0b3 (64-bit)

Actual results:

A small gap appears between spaces toolbar and folder pane.
Usually the gap can be fixed by moving the window or re-opening spaces toolbar

Expected results:

No gap should appear.

Component: Folder and Message Lists → Theme
Severity: -- → S4
Whiteboard: [supernova]

Probably Linux-only, not seeing this on 113.0a1 (2023-03-20) (64-bit), Win10.
Meichthys, do you use display scaling of some sort?

Flags: needinfo?(bugzilla.mozilla.org)
OS: Unspecified → Linux

I can't remember if this was on Windows or Linux. I do use both, and on Linux i do use display scaling, so i think we can chalk it up to that 👍

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Flags: needinfo?(bugzilla.mozilla.org)
Resolution: WONTFIX → WORKSFORME

To follow up here, i can reproduce this on Linux when scaling is set to something above 100%.
Probably no need too re-open this since it's an edge case related too the OS.

Should this be happening/reopen?

Flags: needinfo?(alessandro)

This obviously shouldn't happen.
I can't reproduce it on elementary OS, which is GTK based.
In the original message it says "Linux Plasma desktop", which is Qt based, so very different. And there's also the fractional scaling scenario to consider, which behaves differently between X11 and Wayland.

Let's see if Micah or Richard can reproduce this and maybe find a solution.

Flags: needinfo?(richard.marti)
Flags: needinfo?(micah)
Flags: needinfo?(alessandro)

For reference, I was still using X11.
BTW, I liked the podcast 👍

I don't see this. Maybe it's an issue with the width calculation for --spaces-total-width.

Flags: needinfo?(richard.marti)
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Richard,
For me it sometimes requires some playing with the sidebar. If i hide the sidebar and then restore it, resize the window, or minimize/reopen can sometimes trigger the issue.

I was unable to reproduce on Fedora 37 (GNOME) on wayland or x11 at 100% or 200% scale.

Flags: needinfo?(micah)

I believe that this happens under certain circumstances, but if no one is able to reproduce, looks like this is going nowhere, which is worksforme... (trivial issue, minimally odd, but not detrimental).

Summary: Two pixel gap between Spaces and Folder Pane → Two pixel gap between Spaces Toolbar and Folder Pane with > 100% display scaling on Linux
Whiteboard: [supernova] → [Supernova3p]
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → WORKSFORME

I was able to reproduce it on Windows at 150% scaling and a ltw-theme.
I have a fix!

Status: RESOLVED → REOPENED
OS: Linux → All
Resolution: WORKSFORME → ---
Assignee: nobody → alessandro
Target Milestone: --- → 116 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a576d9924e3b
Remove the 1px extra spacing from the space toolbar width. r=Paenglab

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED

Comment on attachment 9340808 [details]
Bug 1821574 - Remove the 1px extra spacing from the space toolbar width. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9340808 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: