Closed Bug 1821804 Opened 1 year ago Closed 1 year ago

Prevent visual focus moving away from the selected message

Categories

(Thunderbird :: Folder and Message Lists, enhancement)

Thunderbird 112
enhancement

Tracking

(thunderbird_esr102 unaffected, thunderbird112 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- fixed

People

(Reporter: aleca, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(1 file)

Clicking on a selected message subject line temporarily changes the focus from the message (actually the treelist body item) to the child element that is clicked (div, button, image, etc).

The selection doesn't actually change, but visually it looks jarring.
We can prevent this with some simple CSS.

Status: NEW → ASSIGNED
Target Milestone: --- → 112 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c16ef0b59e45
Ensure the currently selected message row remains visually selected when the focus moves within. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1818326
Regressions: 1829194
Whiteboard: [supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.