XHTML about: page (Help->About Mozilla) is handled as plain XML and won't parse

RESOLVED DUPLICATE of bug 197520

Status

RESOLVED DUPLICATE of bug 197520
16 years ago
14 years ago

People

(Reporter: mozilla.org, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Googlebot/2.1w (+http://googlebot.com/bot.html)
Build Identifier: 

Since 1.2beta or earlier, and still in 1.2, Help->About Mozilla gives me an
error message:

XML Parsing Error: undefined entity
Location: jar:resource:///chrome/en-US.jar!/locale/en-US/global/about.xhtml
Line Number 95, Column 15:

Then there is some HTML.  I'm not sure whether to quote it, so I'll just
describe it:  it indicates that the problem is with the "copy" entity.

This indicates to me that the about: page is an XHTML file, but it is being
parsed without regard to the XHTML DTD.


Reproducible: Always

Steps to Reproduce:
1.  Help->About Mozilla
2.  observe bug
Wfm Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021126

Try perhaps with a new profile.

Comment 2

16 years ago
I see the same thing using Mozilla 1.2 on Mac OS X 10.2.2 with a fresh profile.
 Hopefully Bugzilla will quote the HTML in this:

XML Parsing Error: undefined entity
Location: jar:resource:///chrome/en-US.jar!/locale/en-US/global/about.xhtml
Line Number 95, Column 15:

<li>Copyright &copy; 1998-2002 by <a href="about:credits">Contributors</a> to 
--------------^

Comment 3

16 years ago
WorksForMe using FizzillaMach/2002112507.

Comment 4

16 years ago
WFM with Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2) Gecko/20021126

Comment 5

16 years ago
mozilla.org@adb.enki.net , can you still reproduce this problem using a current
nightly build?

Comment 6

16 years ago
Duplicate of 197520.

Comment 7

16 years ago
Resolving dup per comment 6.

*** This bug has been marked as a duplicate of 197520 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.