Closed Bug 1822064 Opened 1 year ago Closed 9 months ago

When activating columns related toolbar buttons with the enter key, selected message should not be opened

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: pvagner, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [Supernova3p])

Testing with thunderbird 112.0a1 20230312

Steps to reproduce

  • Open Thunderbird and use tab / shift+tab or F6 / shift+F6 to focus the message list
  • Make sure a message is selected.
  • Press shift+tab key to navigate to the button Choose columns to display or any other button used for reordering the list.
  • Press the enter to activate that button

Actual results

The popup menu is displayed or the action is performed however it's dismissed because the selected message is open in a new tab or a new window depending on the config.

Expected

The selected mesage should not be opened when activating the buttons.

Keywords: access
Whiteboard: [supernova]
Whiteboard: [supernova] → [Supernova3p]

I can't reproduce this anymore, does it still happen?

Flags: needinfo?(pvagner)

Hello,
Yes I can no longer reproduce this so most likelly it has been fixed as a part of a different change.

Thank you

Flags: needinfo?(pvagner)
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.