Justify + french accent cause strange space behavior in printing

RESOLVED WORKSFORME

Status

()

P3
major
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: mathieu, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3a) Gecko/20021117
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3a) Gecko/20021117

I wrote a paragraph full of french accent. Then print it. It's ok since I don't
choose the 'justify' paragraph style.

Reproducible: Always

Steps to Reproduce:
1. Go to http://malat.free.fr/Justify.html
2. Print it
3. If you prefer you can also take a look at : http://malat.free.fr/Justify.ps.gz

Actual Results:  
You'll see there are spaces after acute and grave accent but smaller space with
 cicumflex

Expected Results:  
Respect spaces just as in Left/Right Or center paragraph style.

Updated

16 years ago
Summary: Justify + french accent cause stange space behavior in printing → Justify + french accent cause strange space behavior in printing

Comment 1

16 years ago
Confirmed. The postscript output from this page contains incorrect spacing after
each of the accented characters. The circumflex-o appears to have a narrower
than normal space following it; the other accented characters all have extra
space following them. This is not visible in print preview; you have to print to
a printer or file and inspect the result.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Created attachment 111634 [details]
http://malat.free.fr/mozilla/Justify.html printed using 2003-01-10-08-trunk and Xprint module (300 DPI, DIN-A4)

Reporter:
Does this PostScript job print OK for you ?

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future
Reassigning to myself. jubei on IRC pointed to a similar problem at
http://www.linuxprinting.org/kpfeifle/LinuxKongress2002/Tutorial/III.PostScript-and-PPDs/III.PostScript-and-PPDs.html
Assignee: rods → smontagu

Comment 4

16 years ago
I am the "Jubei" Simon referred to in comment #3. I can be reached at my email
address if I'm not on IRC.

Note that the spacing errors demonstrated in the URL given in comment #3 are
occuring on non-french characters. The non-letter characters such as quote
symbols and the (R) symbol seem particularly susceptible. The page prints OK if
the <p align="justify"> tags are replaced with plain <p> tags.

Comment 5

16 years ago
Also observing this bug on
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130
on Debian Woody. I remember having seen this bug months (maybe
years) ago. It is an old one.

Comment 6

16 years ago
happens with any text with
the text-align CSS property set to justify .

Comment 7

16 years ago
I think this is a dup of bug #144317 "Printing justified text
with non-ASCII characters mangles spacing".

Comment 8

15 years ago
The bug is still there with iso8859-2 characters 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030722 Mozilla Firebird/0.6

Comment 9

15 years ago
I wonder how could developers see that this _is_ actually a show stopper.
FOr instance: mozilla composer + printing could otherwise function as a
cross-plataform wysiwyg text editor.

Actually, more than one work of mine I'd have preferred to make inHTML, I had to
put into an word processor because of this bug alone.

Someone with the permissions to that will please:
- assign it a (close) milestone to get fixed.
- Change OS to ALL!

Comment 10

15 years ago
Did anyone check whether the issue is present in the attached sample printout
(attachment 111634 [details]) or not ?

Comment 11

15 years ago
Created attachment 128868 [details]
This shows the problem

The existing atachment doesn't show the problem, since the
words taht take an accend are not in lines witch spams to the
full width of the page, with Mozilla breaking them.

This attachment takes a more real-life text, and the
nasty wrongdoings of the terrible BUG 182217 can clearly be seen.

Comment 12

15 years ago
Comment on attachment 128868 [details]
This shows the problem

Can you please attach the HTML source for this attachment, please ?

Comment 13

15 years ago
Created attachment 128870 [details]
HTML source for the previous attachment.

HTML source for the previous attachment.

Comment 14

15 years ago
They are also a strange feature :
1) Set the text as justify (normal text, no "strange" character)
2) Select the justify Text
3) Print the selection

Result : The printed document are "selected" (printed with the higlight)

Testes on Mozilla 1.2.1 and "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624" and "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030917"

Comment 15

15 years ago
If this one is gonna be open forever could somoeone at least mark this as a 
duplicate of bug 144317? 
 
It is just not "french accents" that fails. 
 
As for this "print the highlited selection" new thing, I am not sure if it is 
related. I will make some tries now with iso-8859-x and utf-8 encodings, and 
also try this highlited selection. I shall post my findings on bug 144317, 
which is the older of both. 
(Reporter)

Updated

15 years ago
Severity: normal → major
OS: Linux → All

Comment 16

15 years ago
Marking as a dependence of 144317.
They are several characters affected, and in slightly different ways. It might
be a full duplicate of 144317, but we'd better have a full testing of all cases
to make sure a fix to 144317 really solves all problems.
Depends on: 144317
*** Bug 274282 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
Attachment testcase from comment 13 and URL from comment 0 work for me 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050816
Firefox/1.0+

Does it work (or still fail) for the rest of you?

Comment 19

13 years ago
WFM (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050718
Debian/1.7.8-1sarge1)

Comment 20

13 years ago
-> WFM

However, blocker bug 144317 is not fixed. So either bug 144317 not a blocker or
fixed, or this bug is not whole dependent on it.

Can someone with linux please check the testcase in 144317? (it is marked linux
only)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

13 years ago
The page:
http://malat.free.fr/mozilla/Justify.html 
when being printed still behaves the same. Whitespaces are being inserted after
non-ASCII character (in justify). The bug is still open for linux. I could not
reproduce it with mozilla 1.7.3 on windows XP.

I believe this bug can be mark as duplicate of bug #144317 
Status: RESOLVED → REOPENED
OS: All → Linux
Resolution: WORKSFORME → ---

Comment 22

13 years ago
I confirm that this bug is still present (in Firefox 1.0.7 under Linux).
Positive or negative whitespaces are inserted.

Comment 23

11 years ago
The bug is still present (in Firefox 2 under Linux); does not occur under Windows.

Example: http://siteouebe.free.fr/public/ffbug.html
How printing looks like: http://siteouebe.free.fr/public/ffbug.pdf


Comment 24

10 years ago
Bug is definitely fixed in Firefox 3 under Linux.

Comment 25

10 years ago
Thomas, does attachment 83440 [details] of bug 144317 also work for you?
Assignee: smontagu → nobody
Status: REOPENED → NEW
QA Contact: sujay → printing

Comment 26

10 years ago
(In reply to comment #25)
> Thomas, does attachment 83440 [details] of bug 144317 also work for you?

Yes, both with FF2 and FF3. All characters are printed correctly.

Comment 27

8 years ago
Thomas, thanks for testing that.
WFM per comment 24
Status: NEW → RESOLVED
Last Resolved: 13 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.