Closed Bug 1822473 Opened 1 year ago Closed 10 months ago

TB should always get emails at startup according to the preferences even if the current folder isn't inbox

Categories

(Thunderbird :: Preferences, defect)

Thunderbird 113
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird112 affected, thunderbird113 affected)

RESOLVED INVALID
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- affected
thunderbird113 --- affected

People

(Reporter: NicolasWeb, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

STR:

  1. Check that for at least two accounts have Account Settings > Server settings > Check for new messages at startup enable
  2. Select another folder than inbox of the same account (in my case inbox/xyz)
  3. Quit TB for a long time (the night in my case) & Restart TB next morning
  4. Select the Inbox folder
  5. Select again another inbox subfolder (in my case the same as in step 2), & restart TB

Actual results:

  • Step 3: TB do not check for new emails
  • Step 4: TB check for new emails, including inbox sub folders, (but seems only for the current account)
  • Step 5: TB checks for new emails at startup

Expected results:

  • TB should always check for all new emails at startup if the related preferences are enabled

Seems to me that this happened to me sometimes with TB 111 and 112, but intemittent.

Whiteboard: [Supernova] → [Supernova3p]

Nicolas,
Are you still seeing this?

I don't see other reports of this in https://mzl.la/3YRJSn8

Flags: needinfo?(mozilla.nicolasweb)

Yes Wayne,
I still experience this with 119.0a1 build 20230829103657 and build 20230831101402

I'm on a mac, so not using sys tray, but I experience the same behavior Need to click on the (inbox ?) folder to get new messages as in bug 1843810 (as it is almost empty, I didn't set any fields to link these two. Be free to do it ;-) )

Here is a screen capture (check your matrix chat):
https://nuage.liiib.re/s/5xW89LbcsXPCEMg

Flags: needinfo?(mozilla.nicolasweb)

I didn't set any fields to link these two. Be free to do it ;-) )

You must click Edit Bug at the top right, which will reveal the edit files, such as See Also:

See Also: → 1843810

Wayne,
I checked with a totally fresh new profile (with the same accounts, btw), and I can't reproduce anymore this bug.
Would you me just to close it as WFM or would you me to log something in the console error (what then ?) to better understand the bug's root ?

Flags: needinfo?(vseerror)

You can close it.

Flags: needinfo?(vseerror)
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.