Page opened from NY Times email uses incorrect charset

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Nick Guarracino, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126

I receive the NY Times headlines via email each day.  It comes in HTML format,
with links to the articles from the headlines.  If I click on a headline, the
article opens in a new browser window, but the character encoding is set to
Unicode, even though it's set to ISO-8859-1 (Western) in the page.  This doesn't
happen if I go to the page manually, only when I click on a link from the email.

Reproducible: Always

Steps to Reproduce:
1. Open NY Times email
2. Click on a link to an article

Actual Results:  
Article opens with Unicode as the charset

Expected Results:  
Article opens with ISO-8859-1 as the charset
(Reporter)

Comment 1

15 years ago
Created attachment 107606 [details]
Example email message
-> Mailnews (or INT ?)
Assignee: asa → sspitzer
Component: Browser-General → Mail Window Front End
Product: Browser → MailNews
QA Contact: asa → olgam
Version: Trunk → other

Updated

15 years ago
QA Contact: olgam → laurel
(Reporter)

Comment 3

15 years ago
I mentioned above that the charset was specified in the page we're opening up. 
I'm not sure if it's *correctly* specified though.  The NYTimes specifies it as

<meta http-equiv="charset" content="iso-8859-1">

instead of the more conventional

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">

Also, this is appearing from more than just the NYTimes email that I first
mentioned.  I see it frequently when opening pages linked from other email &
news messages, and it only seems to happen when the charset is not defined (or
possibly defined incorrectly as I just said).

Comment 4

15 years ago
Here's a direct link that shows the error right in the browser:

http://www.nytimes.com/2003/03/09/international/middleeast/09IRAQ.html?th

The page info dialog shows encoding as UTF 8, but the list of meta tags shows a
charset entry specifying iso-8859-1. The article displays correct when accessed
via a link on the front page.

Comment 5

15 years ago
Created attachment 116691 [details]
Page info dialog

Comment 6

15 years ago
There are a handful of NYT bugs, but the closest I could find to a dupe of this 
was bug 128640.  However, the NYT seems to have fixed its header problem; all 
the pages I've downloaded from it are detected as ISO-8859-1, and include the 
proper header:
  <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.