when using url bar to perform search it interprets search terms as a hostname not as a search

RESOLVED DUPLICATE of bug 135363

Status

SeaMonkey
Location Bar
--
minor
RESOLVED DUPLICATE of bug 135363
16 years ago
4 years ago

People

(Reporter: Matthew T. Pandina, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126

After interpreting search terms as a hostname because the user forgot to select
"Search Google for:", it will not perform a search if you arrow down to "Search
Google for:" and press the Enter key, however using the mouse to click on it
will work.

Reproducible: Always

Steps to Reproduce:
1. Enter search terms into the URL bar, but forget to select "Search Google
for:" and just press enter. As expected it tries to interpret the search as a
hostname.
2. While it is trying to look up the non-existent hostname, click on the Stop
button, and back on the URL bar.
3. Press the Down-Arrow key until "Search Google for:" is selected.
4. Press the Enter key to attempt to initiate the search.
Actual Results:  
Pressing the Enter key will cause it to interpret the search as a hostname even
though "Search Google for:" was selected.

Expected Results:  
It should have performed a search on the search terms.
This was already filed a few days ago
Whiteboard: DUPEME

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 135363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.