Closed Bug 1823038 Opened 1 year ago Closed 9 months ago

Unable to delete multiple emails in succession

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED DUPLICATE of bug 1819780
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: denschub, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Pre-Supernova, my workflow was to select the first unread message in the message list, then press the delete key on the keyboard to get rid of it it needed. Thunderbird would then select the next message, allowing me to press delete again, or use the down-arrow to skip the message.

Supernova broke this behavior. Deleting a message via the keyboard still works, and Thunderbird shows the next message. However, pressing the delete key again now does nothing - I first have to select that message with the arrow key down, then press delete.

Are you using IMAP mark-as-deleted? If so, I think this is a duplicate of bug 1815096?

Flags: needinfo?(dschubert)
Keywords: regression
Whiteboard: [Supernova]

Are you using IMAP mark-as-deleted?

I'm not, I'm moving the emails into a Trash folder.

For the record, when I delete a message with the three-pane-layout, the next message's contents are visible in the content pane, and the next message in the message list has a dashed outline, but not a solid "selected" background.

Flags: needinfo?(dschubert)

How is 112.0b4?

Flags: needinfo?(dschubert)

(In reply to Wayne Mery (:wsmwk) from comment #3)

How is 112.0b4?

Same issue, unfortunately. Same with b5!

Flags: needinfo?(dschubert)
Whiteboard: [Supernova] → [Supernova3p]

Probably a duplicate of bug 1819780 as this might happen due to focus change.
Does this happen every time or randomly after deleting a few messages?

Flags: needinfo?(dschubert)

Upon further testing, this appears to be somewhat random, it's not 100% of the time!

Flags: needinfo?(dschubert)

I can confirm I can't reproduce this anymore, bug 1819780 fixed the issue.

Status: NEW → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1819780
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.