Closed Bug 1823055 Opened 1 year ago Closed 11 months ago

"Mark Thread as read" is disabled for thread with unread messages, pressing `R` has no effect.

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 111

Tracking

(thunderbird_esr102 unaffected)

RESOLVED DUPLICATE of bug 1823548
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: tbrownaw, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-efficiency, ux-mode-error, Whiteboard: [Supernova3p][STR comment 2])

Steps to reproduce:

(After updating to 111 beta - I think it was .0b3? - and still on current 112.0b1. )

Filter the view to "Unread" (the button on the quick filter toolbar).

Select a message, and press the "r" key.

Select a different message.

Actual results:

The message shows as unread until I select a different message.

Expected results:

The message should show as read immediately after pressing the "r" key, without needing to select a different message first.

Very similar to bug 1818118. (And still an issue on daily.)

Component: Untriaged → Folder and Message Lists
Keywords: regression
See Also: → 1818118
Summary: "mark as read" when filtered to unread doesn't immediately appear to work → "mark as read" when quick filtered to unread doesn't immediately appear to work
Whiteboard: [Supernova]
See Also: → 1824478

Ouch. Confirming (with some alterations) for 113.0a1 (2023-03-25) (64-bit), Win10. Any actions involving read/unread are messy atm.
I'll morph this a bit to cover Mark Thread read, which is somewhat distinct from bug 1824478.
Looks like a somewhat significant loss of functionality/ux-efficiency which should be fixed asap.

STR

  1. Uncheck ≡ > Settings > General > Reading & Display > Automatically mark messages as read to avoid artifacts from that (pls remember this later!)
  2. Select all messages of an open thread in Threaded mode (Classic 3-pane) and mark them unread by pressing M once or twice as required. Due to bug 1824478, you need to select another message outside the thread to see the updated current read status of the thread messages.
  3. When you're sure the thread is completely unread, right-click any message of the thread, and observe the enabled status of Mark > Thread as Read.
  4. Press Escape to close context menu, ensure that a message of unread thread is still selected, and press R (for Mark Thread Read).

(When done testing, remember to change your Automatically mark messages as read setting back to what it was!)

Actual

  • "Mark Thread as read" is disabled for thread with unread messages
  • Consequently, pressing R has no effect (likely because the command is disabled).

Expected

  • "Mark Thread as read" should be enabled for thread with unread messages
  • Pressing R on thread with unread messages should mark all messages of the thread as read.
Blocks: sn-msglist
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
See Also: → 1820006
Summary: "mark as read" when quick filtered to unread doesn't immediately appear to work → "Mark Thread as read" is disabled for thread with unread messages, pressing `R` has no effect.
Whiteboard: [Supernova] → [Supernova][STR comment 2]
No longer blocks: sn-quickfilter

Seems to work ok on the current daily.

Potentially this was fixed by bug 1823548.
tbrownaw, are you able to test this on Daily?

Flags: needinfo?(tbrownaw)

Yes, this now works properly on 113.0a1 (2023-03-30).

Flags: needinfo?(tbrownaw)
Status: NEW → RESOLVED
Closed: 11 months ago
Duplicate of bug: 1823548
Resolution: --- → DUPLICATE
Duplicate of this bug: 1826585
Whiteboard: [Supernova][STR comment 2] → [Supernova3p][STR comment 2]
You need to log in before you can comment on or make changes to this bug.