Closed Bug 1823274 Opened 1 year ago Closed 11 months ago

When canceling a newsgroup message, TB no longer checks the sender address (From) for a match with the own account. (nntp-js)

Categories

(MailNews Core :: Networking: NNTP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr115 fixed, thunderbird118 fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird118 --- fixed

People

(Reporter: infofrommozilla, Assigned: welpy-cw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

When trying to cancel a newsgroup message, the CPP module checked if the article was from the user. If the sender address (From) did not match your own account, an error message was displayed:

https://searchfox.org/comm-central/search?q=cancelDisallowed&redirect=false

The text of the message is still available, but is apparently no longer referenced anywhere.

Keywords: regression
Regressed by: nntp-js

Old code is around here: https://searchfox.org/comm-esr102/rev/87beeccf2ee78b62db06760b96691985d687717b/mailnews/news/src/nsNNTPProtocol.cpp#3365-3414
... and something similar should be hooked at what's calling cancelMessage. This used to be cmd_cancel, which doesn't appear to be hooked up anywhere for Supernova. https://searchfox.org/comm-central/search?q=cmd_cancel%22&path=mail&case=false&regexp=false

(In reply to Magnus Melin [:mkmelin] from comment #1)

Old code is around here: https://searchfox.org/comm-esr102/rev/87beeccf2ee78b62db06760b96691985d687717b/mailnews/news/src/nsNNTPProtocol.cpp#3365-3414

And the new one:

https://searchfox.org/comm-central/source/mailnews/news/src/NntpService.jsm#155

... and something similar should be hooked at what's calling cancelMessage. This used to be cmd_cancel, which doesn't appear to be hooked up anywhere for Supernova. https://searchfox.org/comm-central/search?q=cmd_cancel%22&path=mail&case=false&regexp=false

In principle, sending a cancel message pre-Supernova (TB111.0a1) still works.

Summary: When canceling a newsgroup message, TB no longer checks the sender address (From) for a match with the own account. → When canceling a newsgroup message, TB no longer checks the sender address (From) for a match with the own account. (nntp-js)
Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED

As there has some confusion recently where to find this function at all (see Bug 1849285), this small patch adds a "Cancel Message" entry to the mail context menu which is only shown for their own newsgroup postings.

The entry in the menu bar is still shown for all newsgroup messages. Using it for other messages than their own just fails silently, as the check from above is also performed. Maybe removing it from the menu bar altogether is the simplest solution.

Target Milestone: --- → 118 Branch

(In reply to Hartmut Welpmann [:welpy-cw] from comment #4)

As there has some confusion recently where to find this function at all (see Bug 1849285),

The menu item was actually never gone here. I think Brian missed the entry in the hamburger menu.

this small patch adds a "Cancel Message" entry to the mail context menu which is only shown for their own newsgroup postings.

Great, that's Bug 916465 btw.

(In reply to Hartmut Welpmann [:welpy-cw] from comment #6)

The entry in the menu bar is still shown for all newsgroup messages. Using it for other messages than their own just fails silently, as the check from above is also performed. Maybe removing it from the menu bar altogether is the simplest solution.

If you don't bring back the query, you should remove the string (see: comment #0 - probably not the one for the suite).

Until the new position gets around, it means more work for the support staff. 😜

(In reply to Alfred Peters from comment #7)

(In reply to Hartmut Welpmann [:welpy-cw] from comment #4)

this small patch adds a "Cancel Message" entry to the mail context menu which is only shown for their own newsgroup postings.

Great, that's Bug 916465 btw.

Bug 671223 - Bug 916465 is for Seamonkey

(In reply to Alfred Peters from comment #7)

(In reply to Hartmut Welpmann [:welpy-cw] from comment #4)

As there has some confusion recently where to find this function at all (see Bug 1849285),

The menu item was actually never gone here. I think Brian missed the entry in the hamburger menu.

Are you sure? Possibly in TB 102, but it TB 115 (not only) the "Messages" branch seems to be removed from the hamburger menu.

(In reply to Hartmut Welpmann [:welpy-cw] from comment #6)

The entry in the menu bar is still shown for all newsgroup messages. Using it for other messages than their own just fails silently, as the check from above is also performed. Maybe removing it from the menu bar altogether is the simplest solution.

If you don't bring back the query, you should remove the string (see: comment #0 - probably not the one for the suite).

Thanks, will do that!

Until the new position gets around, it means more work for the support staff. 😜

Well, that is to be considered :D

See Also: → 671223

(In reply to Hartmut Welpmann [:welpy-cw] from comment #9)

(In reply to Alfred Peters from comment #7)

The menu item was actually never gone here. I think Brian missed the entry in the hamburger menu.

Are you sure? Possibly in TB 102, but it TB 115 (not only) the "Messages" branch seems to be removed from the hamburger menu.

Correct. I was referring to the normal menu bar.

Would it be possible in a simple way to disable/grey out the item? Then it could remain. Just a thought.

(In reply to Alfred Peters from comment #10)

Correct. I was referring to the normal menu bar.

Would it be possible in a simple way to disable/grey out the item? Then it could remain. Just a thought.

Turns out it's just another line to keep it hidden when canceling a message is not allowed. Initially I tried to enable/disable the menu item, but for some reason that I really don't understand it didn't work. So I will remove the second patch.

Attachment #9349978 - Attachment is obsolete: true
Target Milestone: 118 Branch → 119 Branch

Pushed by kaie@kuix.de:
https://hg.mozilla.org/comm-central/rev/54b5e53eae01
Prevent canceling newsgroup messages not matching own identity. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9349977 [details]
Bug 1823274 - Prevent canceling newsgroup messages not matching own identity. r=mkmelin

[Approval Request Comment]
User impact if declined: User may mistakenly try to cancel other people's postings
Risk to taking this patch (and alternatives if risky): seems low

Attachment #9349977 - Flags: approval-comm-esr115?
Attachment #9349977 - Flags: approval-comm-beta?

Comment on attachment 9349977 [details]
Bug 1823274 - Prevent canceling newsgroup messages not matching own identity. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9349977 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9349977 [details]
Bug 1823274 - Prevent canceling newsgroup messages not matching own identity. r=mkmelin

[Triage Comment]
Approved for esr115

Attachment #9349977 - Flags: approval-comm-esr115? → approval-comm-esr115+
Regressions: 1854023
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: