Closed Bug 1823609 Opened 11 months ago Closed 9 months ago

threaded view: incorrect positioning after message delete

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: hlein, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

Steps to reproduce:

Using Grouped Folders in the classical view.
select a message from the list
delete this message

Actual results:

the message disappears from the list, but
no other message is selected in the list
old message content is still shown in the message pane

Expected results:

after message deletion, the selection in the list should be updated (to the previous or next message in the list)
message content pane should be updated accordingly

Note: this works ok for "normal" (not grouped) folders

Seems to work for me on daily.

Keywords: regression
Summary: grouped folders message list: incorrect positioning after message delete → grouped by sort: incorrect positioning after message delete
Whiteboard: [Supernova]

daily 113.0a1 (2023-03-21) (64-bit)

daily 113.0a1 (2023-03-21) (64-bit)

Tested with daily 113.0a1 (2023-03-21) (64-bit) - problem still present.

That is a normal threaded view, not grouped one.

Summary: grouped by sort: incorrect positioning after message delete → threaded view: incorrect positioning after message delete
Blocks: sn-msglist

Helmut, do you still see this?

Flags: needinfo?(hlein)

It is still present in TB 112.0b5

Flags: needinfo?(hlein)

Seems to be ok in TB 112.0b6

But the problem still appears if a message is not deleted but moved to another (local) folder.

Seems to be back again in TB 112.0b7

Whiteboard: [Supernova] → [Supernova3p]

Is this still happening in the latest daily?
We rebuilt the message list widget and the issue should be gone.

Flags: needinfo?(hlein)

I tried with 115.0a1 (2023-05-22) (64-Bit) and basically it is working.

But I have still seen two problems using grouped folders:

  1. in threaded view with collapsed thread, the subject remains underlined even if all messages have been viewed. The underlining disappears when the underlying folders (in grouped folders) have been opened and the messages read.

  2. sometimes when deleting a whole collapsed thread an empty line with a strange date remains. I could not nail down the circumstances. After opening the underlying folders (in grouped folders) and going back to the group, it disappears.

Flags: needinfo?(hlein)

We will investigate those other issues, but please open bugs for each if you can.
The original issue reported here has been fixed so I'm closing this.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.