Closed Bug 182362 Opened 17 years ago Closed 9 years ago

no password dialog box after fail of PASS command (Mail: POP3 and IMAP)

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: rolo, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

When I first created my mail accounts, I accidently put in the wrong password
for one of them, and told the program to remember it.  After several tries, the
computer stopped asking for a new password when the incorrect one failed.  I
checked a web email client to make sure the server was up, and that I had the
correct password.  Now, when I try to get messages I get an error saying the
PASS command did not succeed because the password supplied is incorrect, but a
password dialog box does not open up to let me put in  a new password.    One
time I did see the behavior described in bug 178796, where the PASS command fail
dialog box looped about a dozen times.
I tried removing the account and creating a new one, but I still don't get a
password dialog box.
I am listing this problem as Normal severity, because it happens to be an email
account I hardly ever use, but this could compromise the users ability to use
the Mail/News program at all.

Reproducible: Always

Steps to Reproduce:
1.Create an account
2.Highlight account
3.Press Get Msgs
4.PASS command fail dialog box opens
5.Hit OK
Actual Results:  
Nothing

Expected Results:  
Either Mozilla should ask for a password when you create the account in step 1,
or it should ask for verification of the login information after step 5.
QA Contact: olgam → laurel
Dup of bug 90338?
Reporter: Have you enabled "Remember Passwords" in preferences under 
Privacy & Security -> Passwords?
R.K.Aa,
Yes, "Remember Passwords" is enabled.  I was able to set up the account properly
after deleting the incorrect information from the stored passwords.  This could
qualify as a duplicate of bug 90338.  However, that seems to be more of a debate
than a bug report.  The problem here is that a novice user, such as myself,
especially one switching over from MS Outlook, isn't going to know that mail
account passwords are stored with the web browser passwords.  Even if you leave
the information where it is, the interface must be more intuitive.  There are
four things that should be done.
1. If the PASS command fails, a dialog box should ask to verify the login
information.
2. If a mail account is deleted, the password information should be deleted.
3. The account setup wizard should ask for a password.
4. The account information should include a password dialog box.
If you already had "Remember Passwords" in preferences under 
Privacy & Security -> Passwords enabled, this is not a duplicate of bug 90338.
*** Bug 184414 has been marked as a duplicate of this bug. ***
*** Bug 195209 has been marked as a duplicate of this bug. ***
Confirming (and updating platform - anyone see this on non-Windows platform?)
due to duplicates. I see this on IMAP accounts, and the duplicates are for POP3.

It also happens for SMTP (bug 155172); I think we just need News to complete the
set :-) There also seem to be a few bugs complaining that various things don't
ask for a password when one is required, which is a similar issue, and may be
the same root cause.

Looking around, it appears to be a recurrence of bug 121926. I've also found
loads of bugs to dupe to this!
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 98
Summary: no password dialog box after fail of PASS command → no password dialog box after fail of PASS command (Mail: POP3 and IMAP)
*** Bug 190146 has been marked as a duplicate of this bug. ***
*** Bug 190806 has been marked as a duplicate of this bug. ***
This behaviour is reproducable under Windows up to Mozilla 1.3b and also under
Linux (just tested with Mozilla 1.2).

Mozilla should test if the stored password is valid. If not the enter password
dialog has to pop up!

At the moment this problem is annoying when using mozilla as mail-client in a
network with changing passwords.

The normal user doesn't want to delete the stored passord deep in the prefs!
As an Admin I reset mail passwords about 2-5 times a month, and it becomes
annoying helping the user with their Mozilla/Netscape passwords.....
This bug will never get fixed if YOU never vote for it....
I just replaced Mozilla 1.3.1 by 1.4b on an x86 Debian Linux.
Mozilla is no more able to send the correct username/password
to the POP3 server. Mozilla has lost my password!
And no dialog allows me to reenter it.

Note: I tried with telnet, no problem with the POP3 server.
This workaround should fix the problem for you. 
Go to tools, password manager, and then click on "manage stored passwords"
Delete the entry "mailbox://[username]@[mailserver]"

Mozilla should then prompt you to reenter your password next time it fetches
your new messages.  
Thanks, this workaround fixed the "no password dialog box" problem.

But in fact I am a victim of bug #205003 which seems caused by a
misconfiguration of the POP3 server with CRAM-MD5 authentication.
So I still cannot access my mail, but it's my provider's fault.
*** Bug 133525 has been marked as a duplicate of this bug. ***
*** Bug 146641 has been marked as a duplicate of this bug. ***
Depends on: 178796
This might be fixed in 1.5 alpha?

I just failed to log in with a saved (incorrect) password tonight, running the
new 1.5 alpha, and Mozilla popped up the password entry dialog box again, as it
should do for failed passwords.  This is good.
I also tested 1.5a and this bug is still there.
what about 1.5 final? I think this is a dup of a fixed bug.
I have used Mozilla 1.5 on W2000 with Exchange Imap for some time. After being
forced to change my network password I can't use Mail anymore. Deleting the
stored passwords from the password manager did not solve the problem and it does
not give me a dialog box.

Is ther any other workaround, like deleting some file/line?

User agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
I've a similar problem with 1.6 (I've been forced to reinstall 1.5). Here the
trace of ethereal 

Mozilla 1.5 pop3 mail read:

    No. Time        Source                Destination           Protocol Info
      2 1.756152    192.168.100.101       192.168.100.254       TCP      1834 >
pop3 [SYN] Seq=2299557615 Ack=0 Win=65535 Len=0
      3 1.756368    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [SYN, ACK] Seq=10936264 Ack=2299557616 Win=8760 Len=0
      4 1.756389    192.168.100.101       192.168.100.254       TCP      1834 >
pop3 [ACK] Seq=2299557616 Ack=10936265 Win=65535 Len=0
      5 1.759267    192.168.100.254       192.168.100.101       POP     
Response: +OK
      6 1.777364    192.168.100.101       192.168.100.254       POP     
Request: USER xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      7 1.894797    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [ACK] Seq=10936270 Ack=2299557652 Win=8724 Len=0
      8 2.088205    192.168.100.254       192.168.100.101       POP     
Response: +OK please send PASS command
      9 2.088944    192.168.100.101       192.168.100.254       POP     
Request: PASS xxxxxx
     10 2.196790    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [ACK] Seq=10936300 Ack=2299557665 Win=8711 Len=0
     11 2.332361    192.168.100.254       192.168.100.101       POP     
Response: +OK 0 messages ready for marco.minardi
     12 2.332947    192.168.100.101       192.168.100.254       POP     
Request: STAT
     13 2.454110    192.168.100.254       192.168.100.101       POP     
Response: +OK 0 0
     14 2.461611    192.168.100.101       192.168.100.254       POP     
Request: QUIT
     15 2.595721    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [ACK] Seq=10936349 Ack=2299557677 Win=8699 Len=0
     16 2.596623    192.168.100.254       192.168.100.101       POP     
Response: +OK MC-link POP3 Server (Version 4.20) shutdown.
     17 2.597953    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [FIN, ACK] Seq=10936399 Ack=2299557677 Win=8699 Len=0
     18 2.598025    192.168.100.101       192.168.100.254       TCP      1834 >
pop3 [ACK] Seq=2299557677 Ack=10936400 Win=65401 Len=0
     19 2.611550    192.168.100.101       192.168.100.254       TCP      1834 >
pop3 [FIN, ACK] Seq=2299557677 Ack=10936400 Win=65401 Len=0
     20 2.611754    192.168.100.254       192.168.100.101       TCP      pop3 >
1834 [ACK] Seq=10936400 Ack=2299557678 Win=8699 Len=0


Mozilla 1.6 pop3 mail read:

    No. Time        Source                Destination           Protocol Info
      3 0.000174    192.168.100.101       192.168.100.254       TCP      1034 >
pop3 [SYN] Seq=2861228829 Ack=0 Win=65535 Len=0
      4 0.000344    192.168.100.254       192.168.100.101       TCP      pop3 >
1034 [SYN, ACK] Seq=2659893 Ack=2861228830 Win=8760 Len=0
      5 0.000366    192.168.100.101       192.168.100.254       TCP      1034 >
pop3 [ACK] Seq=2861228830 Ack=2659894 Win=65535 Len=0
      6 0.003234    192.168.100.254       192.168.100.101       POP     
Response: +OK
      7 0.008998    192.168.100.101       192.168.100.254       POP     
Request: CAPA
      8 0.029870    192.168.100.254       192.168.100.101       TCP      pop3 >
1034 [FIN, ACK] Seq=2659899 Ack=2861228836 Win=8754 Len=0
      9 0.029960    192.168.100.101       192.168.100.254       TCP      1034 >
pop3 [ACK] Seq=2861228836 Ack=2659900 Win=65530 Len=0

it seems a problem into the send of the password.
*** Bug 231555 has been marked as a duplicate of this bug. ***
The workaround from 2003-05-13 only works if there is nothing (or something
valid?) in the "SOCKS" fields for the Proxy server configuration. With something
(wrong) there you'll never get the Password box popping up.

User agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Mozilla 1.6 is the same AFAIK (not tested myself)
*** Bug 255740 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: sspitzer → mail
will be this bug fixed?
i have it in 1.7.12 and it's really annoying...
Assignee: mail → nobody
QA Contact: laurel → message-display
Duplicate of this bug: 312239
this is really core functionality that I don't believe happens anymore and none of the current cc: reply, so => WFM    But if anyone can reproduce please speak up.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.