Closed Bug 1823649 Opened 11 months ago Closed 11 months ago

Update PDF.js to new version b1e0253f29176751c9762f88b5b9765fcf9fc07c from 2023-03-20 13:22:09

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: update-bot, Assigned: calixte)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: NVSmX6NuSi2JGYm9vexIFg])

Attachments

(1 file)

This update covers 4 commits.. Here are the overall diff statistics, and then the commit information.


toolkit/components/pdfjs/content/build/pdf.js | 72 +++++----------
toolkit/components/pdfjs/content/build/pdf.scripting.js | 4 +-
toolkit/components/pdfjs/content/build/pdf.worker.js | 6 +-
toolkit/components/pdfjs/content/web/viewer-geckoview.js | 6 +-
toolkit/components/pdfjs/content/web/viewer.js | 6 +-
toolkit/components/pdfjs/moz.yaml | 4 +-
6 files changed, 38 insertions(+), 60 deletions(-)


8bf5e96af9481dea976b034853095bbf2a3e348e by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/8bf5e96af9481dea976b034853095bbf2a3e348e
Authored: 2023-03-20 12:42:28 +0100
Committed: 2023-03-20 12:51:26 +0100

Only warn about missing --scale-factor CSS-variable for visible textLayers (PR 16162 follow-up)

This is something that I completely overlooked in PR 16162, which in some cases cause the default viewer to incorrectly print warnings.
This can be reproduced with the PAGE scrolling-mode, and/or the PresentationMode, and this patch simply work-around it by checking the visibility as well (since the warning is a best-effort solution anyway).

Files Modified:

  • src/display/text_layer.js

cc9f6650a8c595bd3b2a2723a6f193e63790a122 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/cc9f6650a8c595bd3b2a2723a6f193e63790a122
Authored: 2023-03-20 11:41:57 +0100
Committed: 2023-03-20 11:41:57 +0100

Stop passing in pageColors to the CanvasGraphics-constructor (PR 16075 follow-up)

The pageColors-option was removed from the CanvasGraphics-constructor in PR 16075, hence the code in the API no longer needs to pass in that option; this is something that I missed during review.

Files Modified:

  • src/display/api.js

86cf62699c11a6f346e42fd7ed4f21461ad75fa0 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/86cf62699c11a6f346e42fd7ed4f21461ad75fa0
Authored: 2023-03-17 15:58:07 +0100
Committed: 2023-03-20 11:27:47 +0100

Add a helper, in DOMFilterFactory, to reduce duplication when creating <feFuncX>s

Currently we repeat the same code verbatim multiple times in the DOMFilterFactory, which seems completely unnecessary.

Files Modified:

  • src/display/display_utils.js

c4a725fe981fb0d1f1b5ece7cad378027d25fe98 by Jonas Jenwald

https://github.com/mozilla/pdf.js/commit/c4a725fe981fb0d1f1b5ece7cad378027d25fe98
Authored: 2023-03-19 21:49:27 +0100
Committed: 2023-03-19 22:04:01 +0100

Fix the transfer parameter, for structuredClone, in the LoopbackPort

The way that we handle the transfer parameter is unfortunately wrong, ever since PR 14392 which introduced the code, given that the MDN article originally contained incorrect information; please see https://github.com/mdn/content/pull/23164

By updating the structuredClone call such that it works correctly, we can enable more unit-tests in Node.js environments; please refer to https://developer.mozilla.org/en-US/docs/Web/API/structuredClone#parameters

Files Modified:

  • src/display/api.js
  • test/unit/api_spec.js

The try push is done, we found jobs with unclassified failures.

Needs Investigation (From Push Health):

  • No tests were found for flavor 'plain' and the following manifest filters:
    skip_if, run_if, fail_if, subsuite(name=None), tags(['condprof']), pathprefix(['toolkit/components/pdfjs/test'])

    Make sure the test paths (if any) are spelt correctly and the corresponding
    --flavor and --subsuite are being used. See mach mochitest --help for a
    list of valid flavors.

    • 2 of 2 failed on different tasks
      - test-linux1804-64-qr/opt-mochitest-plain-condprof-1 (N46xe5FfQPWfmARsuFphaQ)
      - test-windows11-64-2009-qr/opt-mochitest-plain-condprof-1 (UOvIsclHQV-eU76qDsfdIw)

Needs Investigation (Other Failed Jobs):

  • test-macosx1015-64-qr/debug-mochitest-devtools-chrome-spi-nw-1
    • 4 of 4 failed on the same (retriggered) task (fKnQ2QD2T5iS8EAAsBG3Og, B3rjUba9SZyrNHuSjbHZlw, O3rQF1D2SpukyH4qxVn5Gg, Pu_lrYWMRRm7VYVsbnIFqQ)
  • test-linux1804-64-qr/debug-mochitest-devtools-chrome-spi-nw-1
    • 4 of 4 failed on the same (retriggered) task (IU9xqdHORb-Hn75guDnDPQ, YfDrjDgVShmDF4Rid_qx-g, JqeOrYDBTci6VCZ4-Ml-QA, Z7rTZ1RMSTWvBEBoyIG4Lg)
  • test-windows11-64-2009-qr/debug-mochitest-devtools-chrome-spi-nw-1
    • 4 of 4 failed on the same (retriggered) task (V8QhOVQ7Ro-8StB9qC85YA, bjCM9oHnRsmyDqosKUlEtQ, GTJDOhWPQb-l4wgxX6M_1Q, YaZymZvNRmmhU1Xf2bXWFw)
  • test-windows11-64-2009-qr/debug-mochitest-devtools-chrome-1
    • 4 of 4 failed on the same (retriggered) task (aKiJOvC_SUCEeLdB-aY0mw, ZrcCSlqKRm24_fnpHEF1TA, IwMGLi4lSSmtH9HnFf9NKQ, PdiNWj8WThO760oudYoELA)
  • test-macosx1015-64-qr/debug-mochitest-devtools-chrome-1
    • 4 of 4 failed on the same (retriggered) task (Bo7EkAQaS8asHXarltejlA, R6jp3pPfROG5NC6RSlxNwQ, IVWIb6xnSXif8n6_908eQg, NL6o0S_xQXmUnQzuj3Vwdg)
  • test-linux1804-64-qr/debug-mochitest-devtools-chrome-swr-1
    • 4 of 4 failed on the same (retriggered) task (COkCiyygQNao4FrMUcmfNw, GFOY60-KS2SgBPZiVCjKOw, Ieuub_D3SVy_Pnm7mtD0uA, EDL17f2jQ5CukiwVxBOwZQ)
  • test-linux1804-64-qr/debug-mochitest-devtools-chrome-1
    • 4 of 4 failed on the same (retriggered) task (JESNZxbASyq6dRh2LlgVCQ, OU9lSPUvQFm827av-XmyCA, Zc70TwUmRhiXidnn0ULZnw, T_eSumk9Stiy0Nz1it-QVw)

These failures could mean that the library update changed something and caused
tests to fail. You'll need to review them yourself and decide where to go from here.

In either event, I have done all I can and you will need to take it from here. If you
don't want to land my patch, you can replicate it locally for editing with
./mach vendor toolkit/components/pdfjs/moz.yaml

When reviewing, please note that this is external code, which needs a full and
careful inspection - not a rubberstamp.

Assignee: nobody → cdenizet
Flags: needinfo?(cdenizet)
Pushed by cdenizet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8e8f79bce3b
Update PDF.js to b1e0253f29176751c9762f88b5b9765fcf9fc07c r=calixte
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
Flags: needinfo?(cdenizet)
You need to log in before you can comment on or make changes to this bug.