Closed Bug 182383 Opened 22 years ago Closed 21 years ago

Downloading and deleting large messages is very slow

Categories

(MailNews Core :: Attachments, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bjd, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

I just upgraded from 1.2a to 1.2
Downloading large messages with attachments is now horribly slow.
Previous versions have been very fast. I am on a 100Mbit LAN
connection talking to a qpopper POP server. Never had any problems
in the past. Receiving a message 1.3Mb in size takes 20 seconds or
so to download. And then the same amount of time to delete from
my Inbox. 

Reproducible: Always

Steps to Reproduce:
1. Download a large message
2. Delete the message
3.

Actual Results:  
Sloooooooow

Expected Results:  
Not so slow.
I noticed sending large emails is also alot slower in the 1.2 release build.
The hard disk gets hammered whilst bundling the message and doing the
MIME encapsulation of attachment (i assume). Then the actual sending
process is very quick. The hard disk gets hit when downloading the same
message and when deleting it. Viewing message is fine.
Returned to Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910
and the problem is not present. So definately a bug in 1.2 final.
I have the exact same problem as Brad describes. Running the same build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

I had a large attachment, just over 8MB, that took about 3 minutes to download
from my POP server which would normally take less then a minute when I was using
1.2b. During the time it was downloading the hard drive was constantly being
accessed and Windows listed Mozilla as not responding.

I also receive a similar problem when saving the attachment, Mozilla was still
responding just very slowly. Deleting the message as well as compacting the
mailbox also cause this to occur.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

I'm still having this problem with 1.2.1, how about you Brad?
QA Contact: yulian → stephend
try also compacting folders. disk grinding is horrible and it takes several
minutes for a folder with mere 2000 messages.
the same goes with rebuilding indexes.
also, attachments sometimes fail to show in a preview pane, on the right of the
header. if you open a message in separate window, attachment is visible.
I haven't experienced this yet in the 1.3a builds. Must have been something with
1.2.
Is this a duplicate of bug 182263 (which is fixed in 1.3 builds)?
Yes it seems to be the same problem.
Another possibility is bug 180516.
Reporter, do you still see this problem with the latest nightly (or even 1.5)?
If not, this bug can be closed. Thanks.
I think this was fixed by some other bug. WFM with latest trunk builds on winXP
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.