Cmd-click on title in window should pop up path

VERIFIED DUPLICATE of bug 175470

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
VERIFIED DUPLICATE of bug 175470
15 years ago
13 years ago

People

(Reporter: S Woodside, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
Add a "path" toolbar item like the one in the OS X Jaguar 10.2 finder. This
would be a replacement for the current Go menu (tab-local history).

See also another alternative bug #182144. I would a path item to adding context
menus to the back/forward buttons (as per finder as well).

Comment 1

15 years ago
"Path" is different from "History". I support a path toolbar item, but it should
operate the same way as in the Finder. Thus if the current URL is
"http://www.sitename.com/directory1/subdirectory/thisPage.html" then the other
items in the list should be:
"http://www.sitename.com/directory1/subdirectory/"
"http://www.sitename.com/directory1/"
"http://www.sitename.com/"

As with the Finder, this menu should also be available by command-clicking on
the title in the windows title bar. A.E. for Mac already has this last feature.

Comment 2

15 years ago
Oops. I meant "I.E." in the last line of that last comment, i.e., Internet Explorer.

A.E. would be "After Earth".
(Reporter)

Comment 3

15 years ago
How about a toolbar item that looks just like the "Path" toolbar item in the
Finder, but says "History" and shows the history?

Brad - I don't think there would be too much use for that, since some sites have
intermediate path steps that don't work.

Comment 4

15 years ago
It's a nice idea but should be an addition not a replacement, AAHIG 'must have
equivalents in the menubar'.

I'll make here a global review, can't we open a new META to have a global
overview of all the navigation.

Using a popup menu in the Go Back/Forward would do the same and users are used
to that, see Bug 163274.

By extending Go Back/Forward with modifiers we would have a consistent way for
navigating in pages, tabs and windows, see Bug 185306 and Bug 155863.
Cmd = windows
Option = tabs
No modifiers = pages

Bug 182144 will overload the location area: favicon+url+autocomplete+go button,
see Bug 181806.
That new combo drop down will be confusing with autocomplete.

Do we really need 2 more new ways, Combo-drop-down and Path, which don't add any
new benefit?

I would agree to have a new Path button, if it's the tree view of local history
by using a hierarchical menu, so the other history (sidebar, go menu, go
back/forward) would be the linear one, which is easier to understand.

Comment 5

15 years ago
Simon, the "path" (not history) pop-up in Internet Explorer's titlebar is useful
to me for sites that are structured that way, and not for all all sites. I think
if we are talking about path icons, it should operate the same way, as it does
in the Finder with the functionality in the titlebar of I.E. and the Finder. If
we are talking about history, I agree with Stephane that local linear history
makes most sense as a pop-up connected to Back and Forward buttons in some fashion.

Note that the Finder has both history and path concepts and that they are two
different things. Moving out in the path is not at all the same as hitting the
back button multiple times.

An actual path function as described in my comment #1 would add a "new benefit".
Having yet another way to show history would not.

Comment 6

15 years ago
Brad, Simon says that some sites can not go to to all intermediate sub-paths.
Eg: a/b/c/d you can not go to a/b/c for example, you'll get an alert (~not
authorized).

Comment 7

15 years ago
I understand that. But there are enough that do work that way to make it a useful feature. I 
use it often enough in Internet Explorer to miss it if it is gone.

Comment 8

15 years ago
See also bug 175470 : IE and Safari show this popup when you cmd-click on the
titlebar. I don't like it implemented as a toolbar item, but that can be useful
for other platforms.

Comment 9

15 years ago
-->pinkerton
Assignee: brade → pinkerton
(Assignee)

Comment 10

15 years ago
i think we should copy IE and safari
Summary: Path toolbar item → Cmd-click on title in window should pop up path
Target Milestone: --- → Camino1.0
This bug has a summary that's a duplicate of bug 175470, a description/comment 0
asking for something different (toolbar icon for tab-local history, which is
essentially implemented via the fix in bug 163274), and proceeds to discuss
several other variations.

It seems to me that the part of this bug that pinkerton likes and has targeted
for 1.0 (comment 8, comment 10) is in fact a duplicate of the older bug 175470,
which is not plagued by discussions/descriptions of several different features.
 Should this bug not be resolved as a duplicate of the older/more straighforward
bug 175470 and the latter then targeted for 1.0?
I agree with comment 11. We should dupe this bug in favor of bug 175470. Any
complaints?

Comment 13

13 years ago
I agree marking as a dup of 175470

*** This bug has been marked as a duplicate of 175470 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.