If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

libmsgimap_s.a error during compile

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
blocker
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: Luke-Jr, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020904 MultiZilla/v1.1.22
Build Identifier: Mozilla 1.2 CVS checkout

c++ -Os -march=i686  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long -Os -march=i686 -fshort-wchar
-pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_luke-jr -DTRACING -g -fno-inline -fPIC
-shared -Wl,-h -Wl,libmsgimap.so -o libmsgimap.so  nsImapFactory.o            
-Wl,--whole-archive ../../../dist/lib/libmsgimap_s.a  -Wl,--no-whole-archive
-L../../../dist/bin -L../../../dist/lib -lmsgbaseutil -lrdfutil_s
../../../dist/lib/libunicharutil_s.a -L../../../dist/bin -lxpcom  -liberty
-liberty -L../../../dist/bin -L/usr/src/cvs/1/mozilla/dist/lib -lplds4 -lplc4
-lnspr4 -lpthread -ldl    -Wl,-Bsymbolic -ldl -lm
../../../dist/lib/libmsgimap_s.a: member
../../../dist/lib/libmsgimap_s.a(nsIMAPHostSessionList.o) in archive is not an
object
collect2: ld returned 1 exit status
make[5]: *** [libmsgimap.so] Error 1
make[5]: Leaving directory `/usr/src/cvs/1/mozilla/mailnews/imap/build'


Reproducible: Always

Steps to Reproduce:
1. make -f client.mk build
2.
3.

Actual Results:  
unusual compile(link?) error

Expected Results:  
compiled

Comment 1

15 years ago
what configure/build flags did you use (your .mozconfig file)?  What distro are
you running?
(Reporter)

Comment 2

15 years ago
I do not use distros. I compile everything onto my system.

[luke-jr@arumekun luke-jr]$ cat .mozconfig
# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#

# Options for 'configure' (same as command-line options).
ac_add_options --enable-crypto
ac_add_options --enable-strip

Comment 3

15 years ago
ok, over to build config because I doubt there's anything in the imap code that
could cause this problem.

what versions of ld/gcc do you have?
Assignee: bienvenu → seawood
Component: Networking: IMAP → Build Config
Product: MailNews → Browser
QA Contact: huang → granrose
Version: other → Other Branch
(Reporter)

Comment 4

15 years ago
[luke-jr@arumekun luke-jr]$ ld --version
GNU ld version 2.12.1
Copyright 2002 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
[luke-jr@arumekun luke-jr]$ gcc --version
gcc (GCC) 3.2
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
--
Also, I just remembered that X had died while I was compiling before. Could
Mozilla's makefiles be leaving an incompletely compiled file somewhere? I tried
rming libmsgimap_s.a and having it relink it, but that didn't help...

Comment 5

15 years ago
try removing the imap object files themselves and rebuild (the .o files). My
guess is that the nsImapHostSessionList.o file is corrupt.
What bienvenu said:  It sounds like a corrupt object file. Do a 'make -C
mailnews/imap clean' and restart your build.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 7

15 years ago
blind verify; invalid and old
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.