Closed Bug 1824078 Opened 1 year ago Closed 1 year ago

Display parent folders in favourites

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird114 fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 --- fixed

People

(Reporter: markus-github, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/112.0

Steps to reproduce:

I have different sub folders that are named the same, like this:

  • Parent A
    • XXX
    • YYY
  • Parent B
    • XXX
    • YYY

Actual results:

When I make both "XXX" folders a favourite, it shows like this in favourites:

  • XXX
  • XXX

Now I don't know the parent folder, which is an important information in this case.

Expected results:

Thunderbird <111 automatically displayed all parent folders like this in favourites, which I'd prefer:

  • Parent A
    • XXX
  • Parent B
    • XXX
Status: UNCONFIRMED → RESOLVED
Type: enhancement → defect
Closed: 1 year ago
Duplicate of bug: 1822523
Keywords: regression
Resolution: --- → DUPLICATE
Whiteboard: [Supernova]

https://bugzilla.mozilla.org/show_bug.cgi?id=1822523 is resolved (cannot comment there, though) but I still have the issue on 113.0b1. Is this something different?

Whiteboard: [Supernova] → [Supernova3p]

Favorites still don't display any parent folder on 113.0b3 so it looks like this if you have favorites with the same name but different parent.

Yeah this isn't quite right yet.

Status: RESOLVED → REOPENED
No longer duplicate of bug: 1822523
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW

(In reply to Markus from comment #3)

Created attachment 9330106 [details]
Favorites without parent folder
Favorites still don't display any parent folder on 113.0b3 so it looks like this if you have favorites with the same name but different parent.

Markus, how does 102 handle this situation?

Flags: needinfo?(markus-github)

Markus, how does 102 handle this situation?

If I remember correctly it displays all parent folders of favorites and basically looks same like "All folders" view – just with fewer folders (only the favorites + their parents if any). The folder hierarchy in favortites view for the displayed folders is the same like in "All folders".

So e.g. if I have this in all folders ...

  • Project A
    • Errors
      • Low prio
      • Standard (<-- Favorite folder)
      • Urgent (<-- Favorite folder)
  • Project B
    • Errors
      • Low prio
      • Standard
      • Urgent (<-- Favorite folder)
  • Project C
    • Errors
      • ... (no favorites here)

... it showed like this in favorites:

  • Project A
    • Errors
      • Standard
      • Urgent
  • Project B
    • Errors
      • Urgent
Flags: needinfo?(markus-github)

NI myself as we have some potential solutions for this that need to be explored

Flags: needinfo?(alessandro)

102 did a reasonable thing and displayed the parent as well when you favorited a child.
On a related note it's highly annoying that the actual favorite folders themselves do not show that they have expandable children :/

I'll add the missing ancestors like we've got them in the Unread Folders mode.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(alessandro)

This is basically sharing the code from the Unread Folders mode.

Depends on D178489

Target Milestone: --- → 115 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fe8965e134e8
Display ancestors of folders in Favourite Folders mode. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Attachment #9334915 - Flags: approval-comm-beta?

Comment on attachment 9334915 [details]
Bug 1824078 - Display ancestors of folders in Favourite Folders mode. r=aleca

[Triage Comment]
Approved for beta

Attachment #9334915 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: