Closed Bug 1824281 Opened 11 months ago Closed 6 months ago

Delete has very slow UX response - especially in saved searches

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
x86_64
macOS
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird112 wontfix)

RESOLVED DUPLICATE of bug 1824827
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- wontfix

People

(Reporter: mitra_lists, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, Whiteboard: [Supernova3p])

STR
Create a saved search folder on your inbox (for example I have one for addresses not in certain address books)
Open this saved search
Hit delete on the first message
At times (and I'm not yet sure what the conditions are) the the list does not update.
Since messages are often in collapsed threads, its hard to tell visually if the top message is now the deleted message, or is another one in the same thread.
If you click down arrow to go to the next message, the UX updates, and you end up skipping a message -

To be clearer
List shows messages A B C
Click on A ; hit Delete
List shows A B C still
Click down arrow
List shows B and C and C is highlighted

It is not 100% repeatable, and I'm not sure quite what conditions cause it to happen, but its frequent enough that I've deleted the wrong message more than once (which is how I found out that Undo is missing)

Note - this is a potentially data-losing bug, so maybe worth more atention than it might otherwise suggest.

Keywords: perf
Blocks: sn-msglist
Whiteboard: [Supernova]
See Also: → 1824827

Mitra on Wednesday or Thursday, do you still see this in version 113?

Flags: needinfo?(mitra_lists)

Sorry for slow response - been largely offline on vacation.

I'm now running 113.0b2 and my tests just now don't see this problem.

From my perspective, happy to see this closed, and re-open if it recurs.

Flags: needinfo?(mitra_lists)

I think there were other variations of this in the forum, so it might be worth checking there as well.

Whiteboard: [Supernova] → [Supernova3p]

If you still see this when using version 114 (in a few days) please create a performance profile using https://support.mozilla.org/en-US/kb/profiling-thunderbird-performance

Flags: needinfo?(mitra_lists)

I'm still seeing problems like this with deletions (in a saved search of the inbox). It seems worse when I've also selected a quick filter (like Unread).

I'm not sure how to profile it, since its not happening all the time

Flags: needinfo?(mitra_lists)

(In reply to Mitra Ardron from comment #5)

I'm not sure how to profile it, since its not happening all the time

Yeah, that's a problem. One thing you can do is have the profiler run longer by reducing the sampling rate AND increasing the buffer size as described at https://profiler.firefox.com/docs/#/./guide-profiler-fundamentals

Are you on beta 116 and have seen the problem in the past several days?

Flags: needinfo?(mitra_lists)

I'm in 116b3, I stopped automatic updates since the problems reported in https://thunderbird.topicbox.com/groups/beta/T09fec4addfe7e46d/116-0b6-bug-really-goofed-up-new-message-handling suggest 116b6 is unusable.

Its unclear if the bugs are all the same - manifesting in different ways, but its consistent, and I've seen it yesterday.

The current behavior matches bug#1824827, i.e. that after TB has been running for a while, deletes start mucking up the list of messages, clicking into another folder and back will display correctly (i.e. with the deleted message removed). Once the behavior starts happening its persistent and happens I believe.on every delete until TB is restarted. The behavior doesnt happen on "J" for Junk or "A" for Archive

Flags: needinfo?(mitra_lists)
Status: NEW → RESOLVED
Closed: 6 months ago
Depends on: 1824827
Duplicate of bug: 1824827
Resolution: --- → DUPLICATE
See Also: 1824827
You need to log in before you can comment on or make changes to this bug.