Need option to perform a sync despite previous syncs (related to a palm hard reset)"

RESOLVED DUPLICATE of bug 222016

Status

--
major
RESOLVED DUPLICATE of bug 222016
16 years ago
9 years ago

People

(Reporter: woodycalifornia, Assigned: cavin)

Tracking

Trunk
x86
Windows XP

Details

(Whiteboard: [adt3])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.2) Gecko/20021126

the sync mozilla addressbook <-> palm addressbook worked perfectly fine after
installing the palm-mozilla-sync, however I performed a hard-reset on my
handheld (had nothing to do with mozilla), and now the palm-mozilla-sync simply
doesn't sync the contents of my mozilla addressbook back to my palm handheld.

Reproducible: Always

Steps to Reproduce:
1. Addresses are both on Palm HH and Palm Desktop
2. Install Mozilla Palm-Sync Module
3. Synchronize Addresses (this works)
4. Now perform a hard reset -> leads to complete data loss on the hh
5. After setting default language and stuff, try syncing
   --> the Mozilla Addressbook won't sync

Actual Results:  
I'm not able to sync the contents of my Mozilla Addressbook to my Palm Handheld.
This really looks like some sort of caching problem?

Expected Results:  
The contents of my mozilla address book should have been fully restored to my
palm handheld.

Comment 1

16 years ago
Well this is because the palm sync is done based on last time the sync was done.
Since no changes on the Mozilla happened after the last sync in this case no
entries are transfered to handheld. Well the solution for now is a manual fix by
editing your (i.e the Mozilla profile used for palm sync) and removing the
PalmSyncTimeStamp entry for each address books. However please donot do this if
you find editing prefs.js confusing. The long term solution would be to provide
an option to resync or complete transfer irrespective of previous sync.

Updated

16 years ago
QA Contact: meehansqa → nbaca

Comment 2

16 years ago
Another workaround would be to export the Mozilla address book in LDIF format,
create a second profile and import the LDIF file. Then use this second profile
to sync. Ofcourse this is inconvenient if you have a POP account.

Ofcourse the best solution has Rajiv stated "...The long term solution would be
to provide an option to resync or complete transfer irrespective of previous sync."

Renaming the summary from "palm sync doesn't  after performing a hard reset on
palm" to "Need option to perform a sync despite previous syncs (related to a
palm hard reset)"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: palm sync doesn't after performing a hard reset on palm → Need option to perform a sync despite previous syncs (related to a palm hard reset)"

Comment 3

16 years ago
Marking nsbeta1. Having an option to perform a sync even though a previous sync
already occured would be helpful in situations such as this user where he lost
all his data on the palm. 
Keywords: nsbeta1

Comment 4

16 years ago
Mail triage team: nsbeta1+/adt3
Assignee: rdayal → cavin
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.4beta
I think this should be a dup of Bug 222016, which will provide the capability to
do a one way sync.
Product: MailNews → Core

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 222016 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Target Milestone: mozilla1.4beta → ---
Product: Core → MailNews Core

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.